camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Walzer, Thomas" <thomas.wal...@integratix.net>
Subject Blueprint/@Produce
Date Wed, 22 May 2013 11:24:09 GMT

Hi guys,

I would like to send a message from a pojo to a blueprint route (Camel 2.10).
Something along the lines:

----
package net.integratix.camel.blueprint;
public class ButtonProducer {
	@Produce(uri="direct:startRoute")
	ProducerTemplate producer;

	public void buttonPressed() {
		producer.sendBody("Hello, Camel!!!");
	}

}
----

<?xml version="1.0" encoding="UTF-8"?>
<blueprint xmlns="http://www.osgi.org/xmlns/blueprint/v1.0.0"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:camel="http://camel.apache.org/schema/blueprint"
       xmlns:context="http://www.springframework.org/schema/context"
       xsi:schemaLocation="
       http://www.osgi.org/xmlns/blueprint/v1.0.0 http://www.osgi.org/xmlns/blueprint/v1.0.0/blueprint.xsd
       http://camel.apache.org/schema/blueprint http://camel.apache.org/schema/blueprint/camel-blueprint.xsd">
  
  <camel:contextScan>
	  <camel:includes>net.integratix.camel.blueprint</camel:includes>
  </camel:contextScan>
    <route autoStartup="true" trace="true" id="rtButton2World">
    	<from uri="direct:startRoute"/>
    	<log message="**** ${body} ***"/>
    </route>
</camelContext>
</blueprint>

----

When I run it, the route is started but no message arrives. I assume my bean is not instantiated.

Any hints?
Thanks! Thomas.
Mime
View raw message