camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cgiera <christoph.gi...@mic-cust.com>
Subject MailComponent/MailConsumer misses Mails
Date Thu, 23 May 2013 09:01:24 GMT
Hello,

I'm facing strange problems when consuming mails from a cyrus mail server.
Some mails were not processed but appear as SEEN in the mailbox.
I've added the mail debug option to the route and I was pretty confused when
analyzing the log:

First poll is quite normal: 14 new mails, 14 get fetched and processed.




Second poll is very confusing to me:
14 new messages and only 11 get fetched.
Missing emails are 266, 267 and 268, but they still exist in the
mailbox(marked as SEEN).

Our camel application was (and still is) the only client which was connected
to this mailbox.
So I've to assume that the camel MailComponent has marked as seen(but not
processed the mail).



We are using camel 2.6.0 and cyrus-imapd-2.3.16-6.el6_2.5.x86_64.

The route looks like the following:


This behaviour is almost everytime reproducable when loading "a lot" of
messages to the mailbox(~25+).
Mailserver log shows that our camel application is the only connected
client. 

Any help/advice/hint would be nice, I don't have a clue what I can do or
where I should start my next analyzes.

kind regards,
Christoph





--
View this message in context: http://camel.465427.n5.nabble.com/MailComponent-MailConsumer-misses-Mails-tp5733010.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message