camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Moquin <fragility...@gmail.com>
Subject Re: camel-blueprint-test issues
Date Sat, 02 Mar 2013 20:17:47 GMT
Awesome, was sure I wasn't crazy. :) Happy it's fixed already!

Ryan
On Feb 28, 2013 3:48 AM, "Claus Ibsen" <claus.ibsen@gmail.com> wrote:

> Hi
>
> Well spotted. I have logged a ticket
> https://issues.apache.org/jira/browse/CAMEL-6111
>
> On Thu, Feb 28, 2013 at 5:32 AM, Ryan Moquin <fragility2.0@gmail.com>
> wrote:
> > I converted a test that was using the camel-test library to the
> > camel-test-blueprint library and it appears that the route runs at least
> > twice, but at the exact same time.  I'm not sure why each route is being
> > created more than once per test.  I do see at the beginning of the test
> it
> > print out that I't loading the bundle activator twice.  I also generated
> a
> > sample camel blueprint project from the maven archetype and it appears to
> > exhibit the same behavior.
> >
> > I'using 2.11-SNAPSHOT btw.  I haven't seen anyone mention this nor did I
> > see anything in jira about it.  Has anyone noticed anything similar?
> >  I decided I'd have to try using karaf pax exam instead since I just
> can't
> > to figure out how to get the blueprint the testing working correctly.
> >  Hopefully someone has seen and gotten past that behavior.
> >
> > Thanks for any suggestions or help!
> >
> > Ryan
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> FuseSource is now part of Red Hat
> Email: cibsen@redhat.com
> Web: http://fusesource.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message