camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: error in plugin maven-compiler-plugin:2.5
Date Wed, 27 Mar 2013 12:26:08 GMT
Hi

You need to install the Java SDK.

And have JAVA_HOME point to the SDK. As it has the needed tools.jar.
Your JAVA_HOME points to the Java JRE.

You may already have installed the SDK. If so then change your
JAVA_HOME to point to that.




On Wed, Mar 27, 2013 at 1:10 PM, takidean <takidean1@hotmail.fr> wrote:
> hi when i use to execute the example in chapter2 spring from package
> camelinaction-source-2103 i get this error !!
> on project chapter2-spring: Fatal error compiling: tools.jar not found:
> C:\Program Files\Java\jre6\..\lib\tools.jar -> [Help 1 Failed to execute
> goal org.apache.maven.plugins:maven-compiler-plugin:2.5:compile
> (default-compile)
> this is pom.xml
>
>     <modelVersion>4.0.0</modelVersion>
>
>     <parent>
>         <groupId>com.camelinaction</groupId>
>         <artifactId>chapter2</artifactId>
>         <version>1.0.0</version>
>     </parent>
>
>     <artifactId>chapter2-spring</artifactId>
>     <name>Camel in Action :: Chapter 2 :: Spring</name>
>
>   <dependencies>
>
>     <dependency>
>       <groupId>org.apache.camel</groupId>
>       <artifactId>camel-core</artifactId>
>     </dependency>
>
>     <dependency>
>       <groupId>org.apache.camel</groupId>
>       <artifactId>camel-spring</artifactId>
>     </dependency>
>
>     <dependency>
>       <groupId>org.apache.camel</groupId>
>       <artifactId>camel-jms</artifactId>
>     </dependency>
>
>     <dependency>
>       <groupId>org.apache.activemq</groupId>
>       <artifactId>activemq-core</artifactId>
>     </dependency>
>
>     <dependency>
>       <groupId>log4j</groupId>
>       <artifactId>log4j</artifactId>
>     </dependency>
>
>     <dependency>
>       <groupId>org.slf4j</groupId>
>       <artifactId>slf4j-log4j12</artifactId>
>     </dependency>
>
>   </dependencies>
>
>   <build>
>     <plugins>
>
>
>       <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>exec-maven-plugin</artifactId>
>         <configuration>
>           <includePluginDependencies>false</includePluginDependencies>
>         </configuration>
>       </plugin>
>
>
>       <plugin>
>         <groupId>org.apache.camel</groupId>
>         <artifactId>camel-maven-plugin</artifactId>
>       </plugin>
>     </plugins>
>   </build>
>
> </project>
>
> and this is my mvn -v
> <http://camel.465427.n5.nabble.com/file/n5729930/Sans_titre.png>
>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/error-in-plugin-maven-compiler-plugin-2-5-tp5729930.html
> Sent from the Camel - Users mailing list archive at Nabble.com.



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
FuseSource is now part of Red Hat
Email: cibsen@redhat.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message