camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Nemish <anem...@gmail.com>
Subject Re: Scala DSL with Scala 2.10
Date Fri, 25 Jan 2013 13:38:11 GMT
Henryk Konsek <hekonsek@...> writes:

> 
> > I have logged ticket
> > https://issues.apache.org/jira/browse/CAMEL-6011
> >
> > And upgrading Scala now.
> 
> Actually this is not a Scala-way to just upgrade the version of the library.
> 
> In fact we should create separated module for 2.10 (cloned from the
> 2.9). New development should take place in 2.10 module while existing
> 2.9 module should be kept for the compatibility reasons.
> 
> Now we force people who want to switch from Camel 2.10 to Camel 2.11
> to migrate all their business code to Scala 2.10 as well. And this can
> be painful for them.
> 
> I can handle this issue if you want, but I strongly recommend to keep
> Scala 2.9 support.
> 
> 

Totally agree. The Scala way to do is to build and publish camel-scala_2.9.2-
2.11.0.jar and camel-scala_2.10-2.11.0.jar so sbt could manage scala version 
automatically. You may want to check http://www.scala-
sbt.org/release/docs/Getting-Started/Library-Dependencies.html#getting-the-
right-scala-version-with

Cheers,
Alexander Nemish


Mime
View raw message