camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pointerness <rohit.venkatacha...@nomura.com>
Subject camel sql
Date Sat, 05 Jan 2013 05:56:07 GMT
Hi,
I am evaluating camel for our product. I am trying to use a camel route in
an existing web application.
We use spring-jdbc queryforlist to fetch data from DB. I thought camel's sql
component should be a straight fit. However I get either bad sql grammar or
class not found when I try to use the sql component. I had success when I
invoked the existing java bean via camel route, but sql for some reason
doesn't work.
The route I am using is <route><from uri="direct"a"><to
uri="sql:{{property.sqlquer}}"/><to uri="someJavaBean"/></route> In the
application the query is stored in a constant. I tried setting it as header
value. Even that did not work. I got a parsing exception, so decided to use
a property file. In both cases I was able to log the sql query and did not
see any error. Even though it's a complex query, it's static.
I then tried a very simple sql query which will return me a single column.
even that is failing.
Any ideas where I am going round. As this is a working porject, I am
confident the build path iscorrect. I  am not able to figure out why I am
getting a class not found for spring's rowmapper.





--
View this message in context: http://camel.465427.n5.nabble.com/camel-sql-tp5724935.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message