camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem jiang <willem.ji...@gmail.com>
Subject Re: Scala DSL with Scala 2.10
Date Wed, 19 Dec 2012 02:31:15 GMT
As Scala doesn't like the Java has a good back ward compatibility, we don't have the plan to
support the Scala 2.10 in Camel 2.11.
Camel 2.11.0 will be released in Q1 of 2013, I think it could possible to support Scala 2.10
in Camel 2.12.

BTW I will try to do some experiment with Scala 2.10 with camel-scala when I get some time
:)  

--  
Willem Jiang

Red Hat, Inc.
FuseSource is now part of Red Hat
Web: http://www.fusesource.com | http://www.redhat.com
Blog: http://willemjiang.blogspot.com (http://willemjiang.blogspot.com/) (English)
          http://jnn.iteye.com (http://jnn.javaeye.com/) (Chinese)
Twitter: willemjiang  
Weibo: 姜宁willem





On Wednesday, December 19, 2012 at 10:05 AM, typerlc wrote:

> Does anyone know if there are plans to support Scala 2.10 with the Scala DSL?  
> I haven't seen anything in the roadmap.
>  
> The reflection API has changed in Scala 2.10 and the existing camel-scala
> code throws an exception.
>  
> I know Scala 2.10 hasn't been finally released, but it's just around the
> corner (Dec 26 is listed on their website for final release).
>  
> Richard
>  
>  
>  
> --
> View this message in context: http://camel.465427.n5.nabble.com/Scala-DSL-with-Scala-2-10-tp5724331.html
> Sent from the Camel - Users mailing list archive at Nabble.com (http://Nabble.com).




Mime
View raw message