camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: OSGI dependencies with camel
Date Tue, 27 Nov 2012 22:42:34 GMT
What's your issue? Can you share your stack trace? Which version of
Geronimo/Camel do you use?
As far as I know, Geronimo is based on Karaf. An Camel is shiped with a
feature file for Karaf to install all the dependencies - and it works.

Best,
Christian

Sent from a mobile device
Am 27.11.2012 22:07 schrieb "lleclerc" <lleclerc@aim-rg.com>:

> Hi,
>
> I got a maven project that use camel-core and camel-http4.
> The project works having both dependency.
>
> Now I want to load this project into my OSGI container (I use Apache
> Geronimo 3.0).
>
> While running on the IDE, all the classes are loaded in the same
> classLoader, so camel-core is able to find camel-http4. But running my
> project on geronimo, camel-core cannot find camel-http4 because they are 2
> independent bundle.
>
> What happens in IDE :
> MyProject depends {camel-core, camel-http4}
>
> What happens using OSGI :
> MyProject depends {camel-core}, {camel-http4} and camel-core can't find
> camel-http4.
>
> That's my understanding of the problem.
>
> What is the best solution to resolve camel-http4 in camel-core using OSGI
> Bundles ?
>
>
> We have been trying something using ComponentResolver and @Inject. Is it
> the
> right way ?
>
>
>
> --
> View this message in context:
> http://camel.465427.n5.nabble.com/OSGI-dependencies-with-camel-tp5723319.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message