camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe San <>
Subject Re: Camel OSGi Question
Date Wed, 22 Aug 2012 15:44:56 GMT
Thanks for the pointer.

When I tried that it failed saying that camel-osgi bundle is not installed.
So I tried to install it as below:

osgi:install -s mvn:org.apache.camel/camel-osgi/1.5.0

and surprisingly it failed with the following error:

karaf@root> osgi:install -s mvn:org.apache.camel/camel-osgi/1.5.0
java.lang.RuntimeException: URL [mvn:org.apache.camel/camel-osgi/1.5.0]
could not be resolved.

I can understand that it tried to find this library in my local maven
repository and at the moment, it does not exist. So why does it not try to
look at the maven central repository?


On Wed, Aug 22, 2012 at 4:40 PM, Christian Schneider <> wrote:

> osgi:install -s mvn:com.myproj/myproject/1.0.**0-SNAPSHOT
> loads the bundle from the configured maven repos. By default it tries the
> maven central repo but also your local repo on your machine.
> As mvn install deploys the bundle to your local maven repo it should work.
> In your question you ommitted the version number. Can you try to add it?
> Christian
> Am 22.08.2012 15:43, schrieb Joe San:
>  Guys,
>> I created a new project using the camel-maven-blueprint archetype to be
>> used in an OSGi container. I ran mvn clean install on my project. Where
>> and
>> how do I deploy this bundle to my OSGi container? I"m using ServiceMix. I
>> had a look at the generated files from the blueprint archetype. In the
>> readme it says the following:
>> Camel Router Project for Blueprint (OSGi)
>> ==============================**===========
>> To build this project use
>>      mvn install
>> To deploy the example in OSGi. For example using Apache ServiceMix
>> or Apache Karaf. You will run the following command from its shell:
>>      osgi:install -s mvn:com.myproj/myproject
>> For more help see the Apache Camel documentation
>> I do not understand how the osgi:install command knows to pick up the
>> bundle and from where? I however tried this command in the command line of
>> my service mix but nothing happened. After hitting enter, the cursor would
>> blink for ever.
>> Any suggestions?
>> Regards,
>> Jothi
> --
>  Christian Schneider
> Open Source Architect
> Talend Application Integration Division

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message