camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Borges <bruno.bor...@gmail.com>
Subject Consumers not being redirected to ActiveMQ slave
Date Wed, 01 Aug 2012 20:00:27 GMT
Hey everyone,

i'm doing some things with Camel and ActiveMQ, and it looks like consumers
from Camel (using activemq:) are not being redirected (not reconnecting) to
an ActiveMQ slave after the master has gone down.

This is the configuration I'm using:

  <bean id="jmsConnectionFactory"
class="org.apache.activemq.ActiveMQConnectionFactory">
    <!-- Verifique o arquivo de hosts da maquin aonde esta aplicacao esta
rodando. -->
    <property
name="brokerURL"
value="failover:(nio://activemq01:61616,nio://activemq02:61616)"
/>
  </bean>

  <bean id="pooledConnectionFactory"
class="org.apache.activemq.pool.PooledConnectionFactory">
    <property name="maxConnections" value="8" />
    <property name="maximumActive" value="500" />
    <property name="connectionFactory" ref="jmsConnectionFactory" />
  </bean>

  <bean id="jmsConfig"
class="org.apache.camel.component.jms.JmsConfiguration">
    <property name="connectionFactory" ref="pooledConnectionFactory" />
    <property name="transacted" value="false" />
    <property name="concurrentConsumers" value="5" />
    <property name="disableReplyTo" value="true" />
    <property name="preserveMessageQos" value="true" />
  </bean>

  <bean id="activemq"
class="org.apache.activemq.camel.component.ActiveMQComponent">
    <property name="configuration" ref="jmsConfig" />
  </bean>

Any idea?

*Bruno Borges*
(11) 99564-9058
*www.brunoborges.com*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message