camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ShlomiJ <shlomij...@gmail.com>
Subject Consumers to ActiveMQ shotdown but not reconnecting, even when failover is used
Date Thu, 16 Aug 2012 14:28:43 GMT
hi there,

Having a machine running an ActiveMQ (5.5.1) broker.

Another machine runs our Camel (2.9.0) context.

The connection between the 2 is set exactly as described in *Using
connection pooling* in  http://camel.apache.org/activemq.html
http://camel.apache.org/activemq.html , with the following configuration:

*brokerUrl* =
failover:(tcp://BROKER:61616)?jms.useAsyncSend=true&maxReconnectDelay=1000&useExponentialBackOff=false&initialReconnectDelay=1000
*concurrentConsumers* = 200

In Camel context we define a thread pool with
poolSize=maxPoolSize=maxQueueSize=200.

The route is a simple 'from activemq' one:

&lt;from uri="activemq:queue:MyQueue" /&gt; &lt;!-- no more parameters here
--&gt;

&lt;threads executorServiceRef="poolRef" /&gt;
... etc.

*_After a while (1 to 2 days) the consumers are gone!_*

During the life-cycle of the application we see many successful
re-connections done by the failover ("/failover.FailoverTransport -
Connection established/").

The "keep alive" I'm familiar with (in order to not have so many
re-connections) is ActiveMQ's wireFormat configuration, but we could not
configure the broker connection with both failover and wireFormat
parameters.

Then after a while, from some point on, it simply stops reconnecting.

We restart the route in order to make it reconnect again.

We might see "/Transport failed: java.net.SocketException: Connection
reset/" in the ActiveMQ's log (I'm not sure that always).
This way or the other, we still expect the consumers to reconnect.

Why does the failover stop reconnecting?

Is there a better configuration to use?

What exactly is getting disconnected? Is it something in ActiveMQ or in
Camel?

thanks for future help

SJ



--
View this message in context: http://camel.465427.n5.nabble.com/Consumers-to-ActiveMQ-shotdown-but-not-reconnecting-even-when-failover-is-used-tp5717552.html
Sent from the Camel - Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message