camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Failed to load type converters
Date Wed, 04 Jul 2012 05:28:06 GMT
Hi

Yes you need to use AMQ 5.6.0 which is compatible with Camel 2.9.x onwards.

If using older AMQ releases you would need to patch the JAR yourself,
eg as Babak has shown below, its fairly simple as you would need to
patch the TypeConverter file in the META-INF dir.

Another alternative is to downgrade Camel. I think either you would
have to go down to 2.8 or 2.7 releases, which was not as strict in
case of failed type converter loading during startup.


On Tue, Jul 3, 2012 at 7:50 PM, Babak Vahdat
<babak.vahdat@swissonline.ch> wrote:
> The problem is the AMQ version you make use of, that's the content of this
> file:
>
> https://svn.apache.org/repos/asf/activemq/tags/activemq-5.4.2/activemq-camel/src/main/resources/META-INF/services/org/apache/camel/TypeConverter
>
> Which in 5.6.0 makes use of FQN:
>
> https://svn.apache.org/repos/asf/activemq/tags/activemq-5.6.0/activemq-camel/src/main/resources/META-INF/services/org/apache/camel/TypeConverter
>
> I'm not aware of any other workaround other than upgrading to AMQ 5.6.0.
> However others in the forum may know about other possible options.
>
> Babak
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/Failed-to-load-type-converters-tp5715415p5715419.html
> Sent from the Camel - Users mailing list archive at Nabble.com.



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus, fusenews
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message