camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: migration camel attachment problem
Date Sat, 02 Jun 2012 21:13:13 GMT
Hello Mathieu!

You should start here [1].
You didn't provide enough information for us to start digging into your
problem.
>From which version to which version did you upgrade?
You didn't mention you use Apache Camel. You may consider to post this
question on the Apache CXF user list?
I didn't understand your explanation: "instead of receive one attachement,
i get 2, but the good one is bad". Could you please explain this more
understandable?
Could you also share your CXF configuration with us?
And also the WSDL file?

[1] http://camel.apache.org/support.html

Best,
Christian

On Thu, May 31, 2012 at 8:41 PM, mathieuJ <mathieu.jambou@gmail.com> wrote:

> hello,
>
> i did a migration of my apache cxf.
>
> Now , i have a problem with the receiption of attachments.
>
> instead of receive one attachement, i get 2, but the good one is bad.
>
>
> response soap:
>
> <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
> <soap:Body>
> <ns2:getEditionResponse xmlns:ns2="http://www.suravenir.fr/ws/edition">
> <editionResp>
> <pdf>
> <xop:Include
> href="cid:ab01c3af-a181-4d81-b056-bca60d267064-32@cxf.apache.org"
> xmlns:xop="http://www.w3.org/2004/08/xop/include"/>
> </pdf>
> </editionResp>
> </ns2:getEditionResponse>
>
>
> attachment:
>
> name content type size part type contentID
>
> e51a406a-f949-41ac-8158-e8f1b910f57a-115@cxf.apache.org application/pdf
> 120861 e51a406a-f949-41ac-8158-e8f1b910f57a-115@cxf.apache.org MIME
> <e51a406a-f949-41ac-8158-e8f1b910f57a-115@cxf.apache.org>
> ab01c3af-a181-4d81-b056-bca60d267064-32@cxf.apache.org application/pdf 0
> ab01c3af-a181-4d81-b056-bca60d267064-32@cxf.apache.org MIME
> <ab01c3af-a181-4d81-b056-bca60d267064-32@cxf.apache.org>
> </soap:Body>
> </soap:Envelope>
>
>
> if someone have an idea where the mistake comes from.
>
>
> before, i had just one pdf and his name was the same that the name contain
> in the answer. but now is none
>
> I think the problem comes because i don't have the same id between my xop
> include and the CONTENTID
>
>
>
> Jambou Mathieu
>
> --
> View this message in context:
> http://camel.465427.n5.nabble.com/migration-camel-attachment-problem-tp5713800.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message