camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From weather99 <fflei...@harris.com>
Subject RE: camel xslt 2.0 support
Date Fri, 22 Jun 2012 11:28:53 GMT
Hi Claus.  Thanks so much for the reply.  I was afraid that might cause some confusion.



I'm saying that an xslt 1.0 transfrom was done because all I got in the translated file was
the prolog and nothing else, not because the xml version was 1.0.



The second example, where I just use a bean, actually shows the error where I get messages
complaining about specific xslt 2.0 tags that it cannot handle.



Thanks.

Frank.





________________________________
From: Claus Ibsen-2 [via Camel] [ml-node+s465427n5714910h90@n5.nabble.com]
Sent: Friday, June 22, 2012 5:27 AM
To: Fleishaker, Frank
Subject: Re: camel xslt 2.0 support

On Fri, Jun 22, 2012 at 11:14 AM, Thibault <[hidden email]<https://mail.harris.com/owa/UrlBlockedError.aspx>>
wrote:
> Are you sure the prolog <?xml version="1.0" encoding="UTF-8"?> indicates
> that a XSLT 1.0 transform was done ? I always thought this one was the
> prolog for the XML version, not for the transform applied...
> In my  case, all my xslt 2.0 transform generates xml version 1.0.
>

Yes thats the XML standard. The world uses v1.0.  I think there is a
1.1 version, but I dont see that in practice.
Its not related to XSLT.

http://en.wikipedia.org/wiki/XML

>
>
> 2012/6/21 weather99 [via Camel] <[hidden email]<https://mail.harris.com/owa/UrlBlockedError.aspx>>
>
>> Despite installing servicemix-saxon, and following the instructions on
>> this and other threads, I still cannot get xslt 2.0 to work in Servicemix
>> 4.4.1 or 4.4.2.  The converted message shows up with only the prolog <?xml
>> version="1.0" encoding="UTF-8"?>, which indicates an xslt 1.0 conversion
>> was done.
>>
>> I'm using this as part of my route:
>> <camel:to
>> uri="xslt:file:xsl/my.xsl?transformerFactoryClass=net.sf.saxon.TransformerFactoryImpl"
>> />
>>
>> I have also tried this same thing via. a bean, with the same result:
>> <to uri="xslt:file:xsl/my.xsl?transformerFactory=tFactory" /> <bean
>> id="tFactory" class="net.sf.saxon.TransformerFactoryImpl" />
>>
>> In order to troubleshoot further, I embedded the entire xslt
>> transformation inside a bean, using the saxon9he jar file.  It worked in
>> standalone Camel.  To make sure I had no external dependencies for the
>> conversion, I built it with the extracted classes from the saxon jar.  When
>> I tried to run it in Servicemix, i got this result:
>>
>> Line #1; Column #473; "xpath-default-namespace" attribute is not allowed
>> on the xsl:stylesheet element!
>> SystemId Unknown; Line #55; Column #86; Could not find function:
>> upper-case
>>
>> This also indicates that only an xslt 1.0 conversion was attempted, since
>> the processor doesn't know what to do with these tags.  This is the bean I
>> was using:  <bean ref="xslt20" method="map" />
>>
>> It appears that in Servicemix, the xalan jar in ./lib/endorsed overrides
>> all xslt processing no matter what.  I tried removing the xalan-2.7.1.jar
>> from that directory.  My route wouldn't start, and I got this message:
>>
>> org.springframework.beans.factory.BeanCreationException: Error creating
>> bean with name 'xslt20' defined in URL
>> [bundle://187.0:0/META-INF/spring/beans-0.0.0.xml]: Instantiation of bean
>> failed; nested exception is
>> javax.xml.transform.TransformerFactoryConfigurationError: Provider *
>> org.apache.xalan.processor*.TransformerFactoryImpl not found
>>
>> So it seems that it's always looking for xalan no matter what, which is
>> only an xslt 1.0 processor.
>>
>> Please advise as to what I'm doing wrong.  We have a lot invested in xslt
>> 2.0 in standalone Camel, and I'm now at a dead-stop trying to deploy it to
>> Servicemix.
>>
>> Thanks.
>>
>>
>>
>>
>>
>> ------------------------------
>>  If you reply to this email, your message will be added to the discussion
>> below:
>>
>> http://camel.465427.n5.nabble.com/camel-xslt-2-0-support-tp5646214p5714877.html
>>  To start a new topic under Camel - Users, email
>> [hidden email]<https://mail.harris.com/owa/UrlBlockedError.aspx>
>> To unsubscribe from Camel - Users, click here<
>> .
>> NAML<<https://mail.harris.com/owa/UrlBlockedError.aspx>http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>
>>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/camel-xslt-2-0-support-tp5646214p5714907.html
> Sent from the Camel - Users mailing list archive at Nabble.com.



--
Claus Ibsen
-----------------
FuseSource
Email: [hidden email]<https://mail.harris.com/owa/UrlBlockedError.aspx>
Web: http://fusesource.com
Twitter: davsclaus, fusenews
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen


________________________________
If you reply to this email, your message will be added to the discussion below:
http://camel.465427.n5.nabble.com/camel-xslt-2-0-support-tp5646214p5714910.html
To unsubscribe from camel xslt 2.0 support, click here<http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=5646214&code=ZmZsZWlzaGFAaGFycmlzLmNvbXw1NjQ2MjE0fC0yNzQ2NjQ0MTQ=>.
NAML<http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=instant_html%21nabble%3Aemail.naml&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.NodeNamespace&breadcrumbs=notify_subscribers%21nabble%3Aemail.naml-instant_emails%21nabble%3Aemail.naml-send_instant_email%21nabble%3Aemail.naml>


--
View this message in context: http://camel.465427.n5.nabble.com/camel-xslt-2-0-support-tp5646214p5714920.html
Sent from the Camel - Users mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message