camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From gramanero <graman...@gmail.com>
Subject Re: HOW-TO: Jetty, JSON, and Restful Services
Date Tue, 29 May 2012 20:05:05 GMT
Thank you for the tip about removeHeaders. I was wondering if there was an
easier way to accomplish that. Very much appreciated!

What I noticed when initially trying to route the message from jetty to the
restulf svc is that the CamelHttpUrl was incorrect. What was logged in the
servicemix.log file was:

http://localhost:5477/MetricsService/Create/MetricsEndpoint/

To me it looks like the jetty endpoint path is being appended to the cxfrs
endpoint and then camel is trying to communicate with that, which obviously
won't work. That is when I started messing with the headers to try and get
them "cleaned up" to what I thought made more sense. Of course, I very well
may be doing more harm than good. When I take out the removeHeader elements
in the route I get the following error:

Caused by: java.lang.IllegalArgumentException: Illegal character(s) in
message header value: HTTP/1.1 200

As far as verifying the restful svc itself, I was able to use the Composer
tab in Fiddler to fire off a JSON request and it all worked just fine. I
basically threw a breakpoint in the .NET restful svc and verified that the
callers data was passed correctly, so based on that it doesn't appear to be
a problem with the service itself. I also got it to work via a powershell
script. I tried using soapUI (and had success with it in the past), but when
the restful svc method gets invoked, the input argument is null. I'm sure
I'm doing something stupid in soapUI, but I didn't feel like fighting with
the tool so I just ended up using Fiddler.

Currently I am running everything on a local workstation.

Thank you for the response!

--
View this message in context: http://camel.465427.n5.nabble.com/HOW-TO-Jetty-JSON-and-Restful-Services-tp5713702p5713712.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message