camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fitzcaraldo <Brian.fitzger...@marlo.com.au>
Subject Re: karaf 2.2.5, cxf 2.6.0 and camel 2.9.0 install problem
Date Tue, 01 May 2012 00:54:39 GMT
I'm now trying to add ActiveMQ 5.5.1 to the above container (karaf 2.2.7, cxf
2.6.0, camel 2.9.2)

features:addUrl mvn:org.apache.activemq/activemq-karaf/5.5.1/xml/features

then

features:install activemq-spring

This fails with the message:

Error executing command: Could not start bundle
mvn:org.apache.activemq/activemq-spring/5.5.1 in feature(s)
activemq-spring-5.5.1: Unresolved constraint in bundle
org.apache.activemq.activemq-spring [199]: Unable to resolve 199.0: missing
requirement [199.0] package;
(&(package=org.apache.activemq)(version>=5.5.0)(!(version>=6.0.0)))

As well as the dependency in AMQ V5.5.0 shown this step also pulls in cxf
2.5.2 again!

Is there another dependency I'm not aware of?

Can someone recommend a combination of the 4 products that work together.



--
View this message in context: http://camel.465427.n5.nabble.com/karaf-2-2-5-cxf-2-6-0-and-camel-2-9-0-install-problem-tp5675060p5677249.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message