camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@googlemail.com>
Subject Re: CxfEndpoint and configure interceptor on bus
Date Wed, 07 Mar 2012 13:43:18 GMT
Hi Andi,

There have been some changes in the wiring between the camel-cxf
endpoints and cxf buses recently. Therefore, there may be some
combination of the cxf and camel versions that could lead to some
issues depending on how they are wired.

That's why I was asking for the camel version and if you could try for
camel 2.9.0.  But as I said before, it's normal when you don't find
the other interceptor when you look into the endpoint, but it is a bug
or some kind of incompatibility issue when one of the interceptors is
not invoked or some exception is thrown during the invocation.

thanks.
regards, aki

2012/3/7 akuhtz <andreas.kuhtz@gmail.com>:
> Hi Aki,
>
> Thanks for your reply. The problem was that the interceptor that was defined
> on the bus was not invoked and even not added to the interceptor chain ....
> but this was a stupid configuration error on my side :-(
>
> With CXF-2.4.4 it was working if <cxfcore:bus id="somebus" ...> was defined
> (wrong usage of the "id" attribute instead of "bus") and with CXF-2.4.6 (or
> newer) this does no longer work. Switching to CXF-2.5.2 threw an exception
> that no bus with this id/name was configured and this lead me to find the
> wrong configuration.
> Sorry for the noise on the camel list because it's a CXF related issue
> caused by my wrong configuration.
>
> Regards,
> Andi
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/CxfEndpoint-and-configure-interceptor-on-bus-tp5541585p5543569.html
> Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message