camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From PAC Kieffer Guillaume <Guillaume.Kief...@panalpina.com>
Subject RE: C3P0 cannot load Jtds Driver in OSGi env
Date Fri, 30 Mar 2012 08:15:25 GMT
Hi,

I have the same need with Informix db on Servicemix environmemt.

I chose DBCP because an OSGi version was available:
org.apache.servicemix.bundles
org.apache.servicemix.bundles.commons-dbcp
1.4_2

It worked nicely until now with a ConnectionFactory service.. And should work not only on
Servicemix..
Maybe your problem is only linked to the dbcp library which was not designed to work on an
OSGi environment. 

Regards,
Guillaume.

ame case with had no issue with Informix drie

-----Original Message-----
From: Reuben Garrett [mailto:reubengarrett@gmail.com] 
Sent: Thursday, March 29, 2012 19:09
To: users@camel.apache.org
Subject: Re: C3P0 cannot load Jtds Driver in OSGi env

glad it worked for you!

Sven's example sounds more elegant and robust for a larger scenario, but
it's pushing the boundaries of my current skill level.  i'll revisit once
i've learned more.

~ Reuben

On Thu, Mar 29, 2012 at 12:02, raad <yacur@yahoo.com> wrote:

> Reuben, I chose your method and it worked fine.  Thanks for the response.
> But I do like the idea of having a fractional bundle where the dbcp and
> the jdbc driver live in the same classpath.
>
Mime
View raw message