camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bhushand <bhushan_bde...@yahoo.co.in>
Subject Re: getting error while deploying application with apache cxf2.5.2
Date Thu, 29 Mar 2012 10:58:56 GMT
Hello Willem,
Yes, I disabled the WAS jaxws engine by setting JVM property under generic
JVM arguments

-Dcom.ibm.websphere.webservices.DisableIBMJAXWSEngine=true

That also did note resolved the problem.

Following is my extract from my web.xml
	<listener>
	
<listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>
	</listener>
	
	
	<context-param>
		<param-name>contextConfigLocation</param-name>
		<param-value>
			/WEB-INF/config/cxf-config.xml
		</param-value>
	</context-param>

	

	<servlet>
		<servlet-name>CXFServlet</servlet-name>
		<servlet-class>org.apache.cxf.transport.servlet.CXFServlet</servlet-class>
		<load-on-startup>1</load-on-startup>
	</servlet>
	
	<servlet-mapping>
		<servlet-name>CXFServlet</servlet-name>
		<url-pattern>/webservices/*</url-pattern>
	</servlet-mapping>




and my cxf config file is as below,

<beans xmlns="http://www.springframework.org/schema/beans"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:jaxws="http://cxf.apache.org/jaxws"
	xsi:schemaLocation="
			http://cxf.apache.org/core http://cxf.apache.org/schemas/core.xsd
            http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
            http://cxf.apache.org/jaxws
http://cxf.apache.org/schemas/jaxws.xsd
            http://www.springframework.org/schema/util
http://www.springframework.org/schema/util/spring-util-2.0.xsd">

	<import resource="classpath:META-INF/cxf/cxf.xml" />
	<import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
	<import resource="classpath:META-INF/cxf/cxf-servlet.xml" />

	
	<bean id="getAccountInformationEndpoint"
		class="com.test.GetAccountInformationImpl">
	</bean>
	
	
	<bean id="searchAccountEndpoint"
		class="com.test.AccountImpl">
	</bean>
	
	<bean id="genericJAXWSHandler" class="com.test.GenericJAXWSHandler" />

	
	<jaxws:endpoint id="getAccountInformation"
implementor="#getAccountInformationEndpoint"
		address="/GetAccountInformation"
		endpointName="s2:GetAccountInformationSOAP"
serviceName="s2:GetAccountInformation"
		xmlns:s2="http://accountInformation.service.test.com">
		<jaxws:handlers>
			<ref bean="genericJAXWSHandler" />
		</jaxws:handlers>
		</jaxws:endpoint>

	
	<jaxws:endpoint id="searchAccount" implementor="#searchAccountEndpoint"
		address="/SearchAccount"
		endpointName="s2:BasicHttpBinding_Account" serviceName="s2:Account"
		xmlns:s2="http://searchAccount.service.test.com">
		
		<jaxws:handlers>
			<ref bean="genericJAXWSHandler" />
		</jaxws:handlers>
		
	</jaxws:endpoint>
		
	
</beans>


Thanks
Bhushan




--
View this message in context: http://camel.465427.n5.nabble.com/getting-error-while-deploying-application-with-apache-cxf2-5-2-tp5601200p5603389.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message