camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From raad <ya...@yahoo.com>
Subject C3P0 cannot load Jtds Driver in OSGi env
Date Wed, 28 Mar 2012 17:45:20 GMT
 So i have wrapped the Jtds and c3p0 jars under install wrap command and I
still get the following when connection is being established:


13:37:14,941 | WARN  | er$PoolThread-#1 | DriverManagerDataSource          |
268 - com.mchange.v2.c3p0 - 0.9.1.2 | Could not load driverClass
net.sourceforge.jtds.jdbc.Driver
java.lang.ClassNotFoundException: net.sourceforge.jtds.jdbc.Driver not found
by com.mchange.v2.c3p0 [268]
	at
org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:787)
	at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:71)



I've looked for blogs with similar issues but they refer to manifest changes
that need to happen.  I import all the packages needed in the pom:  hereis
what I have:

                        <Import-Package>
                                 ...
                       		net.sourceforge.jtds.jdbc,
                       		net.sourceforge.jtds.jdbcx,
              				com.mchange.v2.c3p0,
                            *
                        </Import-Package>


anyone?

--
View this message in context: http://camel.465427.n5.nabble.com/C3P0-cannot-load-Jtds-Driver-in-OSGi-env-tp5601253p5601253.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message