camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: URGENT help please
Date Sat, 26 Nov 2011 12:54:23 GMT
It looks like you application war have some class which is build with 
JDK 1.6. Can you check if there any other third part dependency is build 
with JDK 1.6.

On 11/26/11 4:41 PM, Jose Correia wrote:
> Yeh as I mentioned I did find that link myself, hence why I went back to 2.6.0. However
it did not work it seems, it still failed with same exception... so I went even further back
to 2.5.0... hmm it seems not its in spring... even though spring 3.0.5 seems to be compatible...
sucks... the battle continues.
>
> Thanks for assistance though.
>
> Regards
> Jose
>
> ________________________________________
> From: Claus Ibsen [claus.ibsen@gmail.com]
> Sent: 26 November 2011 10:00 AM
> To: users@camel.apache.org
> Cc: Jose Correia
> Subject: Re: URGENT help please
>
> Hi
>
> Camel 2.6.x or older supports JDK 1.5.
>
> See here for more details
> http://camel.apache.org/2011/02/09/camel-270-drops-support-for-java-15.html
>
>
> On Sat, Nov 26, 2011 at 7:41 AM, Jose Correia<jose@ct.bbd.co.za>  wrote:
>> Hi all
>>
>> My maven-built application (using eclipse sprins source IDE) was being
>> compiled and created using JDK 6. Suddenly the client wanted to go back to
>> jdk5... so I did the usual, went to the jdk compliance preferences and
>> switched it to 1.5. Also in all my poms set the maven-jar-plugin and
>> maven-compiler-plugin to 1.5.
>>
>> I rebuilt war file and deployed on Jboss, it then started spewing on
>> deployment:
>>
>>
>> java.lang.UnsupportedClassVersionError: Bad version number in .class file
>>
>>        at java.lang.ClassLoader.defineClass1(Native Method)
>>
>>
>>
>> And it was pointing at Camel... I was using 2.7.2... which after googling I
>> found out on the camel website that from after 2.6.0 Camel stopped support
>> for 1.5... so I went back to 2.6.0 (quite a mission too as certain depencies
>> of 2.7.2 all of a sudden needed to be specified directly) and rebuilt. Also
>> I then restarted eclipse wit jdk5 and pointed my runtime environment to jdk
>> 5 too.
>>
>>
>>
>> There was an improvement in that on deployment exceptions fell away. However
>> on calling a webmethod of my webservice through soap ui, the same exceptions
>> is thrown... so I went back to camel version 2.5.0.... and same thing.
>>
>>
>>
>> Can anyone tell me which version of camel is really compatible with 1.5?
>>
>>
>>
>> Thanks
>>
>> Jose
>
>
>
> --
> Claus Ibsen
> -----------------
> FuseSource
> Email: cibsen@fusesource.com
> Web: http://fusesource.com
> Twitter: davsclaus, fusenews
> Blog: http://davsclaus.blogspot.com/
> Author of Camel in Action: http://www.manning.com/ibsen/


-- 
Willem
----------------------------------
FuseSource
Web: http://www.fusesource.com
Blog:    http://willemjiang.blogspot.com (English)
          http://jnn.javaeye.com (Chinese)
Twitter: willemjiang
Weibo: willemjiang

Mime
View raw message