camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Embedded Broker, Trying to Load Camel
Date Mon, 29 Aug 2011 02:37:07 GMT
You need to also specify the camel-jms version, as the activemq-camel 
5.5.0 will use the camel-jms 2.7.0 by default.


On 8/28/11 3:19 PM, Taariq Levack wrote:
> Hi there
>
> Your POM is mixing spring versions, you have camel-spring 2.7,
> camel-spring 2.8 also, and then spring 2.5.6 defined.
>
> Camel-spring depends on spring 3.0.5.
>
> So to fix you need to remove all the extra dependencies, and depend on
> camel-spring 2.8
>
> Taariq
>
> On Sat, Aug 27, 2011 at 6:33 PM, sub3<steve@subwest.com>  wrote:
>> Both. Not sure of the terminology.
>> I want to start an AMQ broker from inside a jar (with its config files)
>> with Camel running, so I can add routes.
>>
>> Multiple clients will connect and I want to start mapping some
>> components outgoing queues to others incoming queues. I will be setting
>> up these routes from code inside the jar.
>>
>> The embedded broker w/o Camel starts up fine with
>>   >  BrokerService broker = BrokerFactory.createBroker(new
>> URI("xbean:activemq-base.xml"));
>>   >  broker.start();
>>
>> But as soon as I add the 'import camel.xml' line, it has the issues
>> described previously.  An alternative might be to start it up via code.
>> Can I do that?
>>
>> Thanks.
>>
>>
>>
>> On 8/27/2011 11:42 AM, BASE Logic, Inc. [via Camel] wrote:
>>> Are you trying to run camel? Or are you talking about an embedded AMQ
>>> broker?
>>>
>>> ---
>>> Thank You…
>>>
>>> Mick Knutson, President
>>>
>>> BASE Logic, Inc.
>>> Enterprise Architecture, Design, Mentoring&  Agile Consulting
>>> p. (855) BASE-LOGIC: (227-3564-42)
>>> p. (478) BASE-LOGIC (227-3564-42)
>>> f. (855) BASE-LOGIC: (227-3564-42)
>>>
>>> Website: http://www.baselogic.com
>>> Blog: http://www.baselogic.com/blog/
>>> Linked IN: http://linkedin.com/in/mickknutson
>>> Twitter: http://twitter.com/mickknutson
>>> ---
>>>
>>>
>>>
>>> On Sat, Aug 27, 2011 at 11:34 AM, sub3<[hidden email]
>>> </user/SendEmail.jtp?type=node&node=4741501&i=0>>  wrote:
>>>
>>>> Thanks for your replies.
>>>>
>>>> I am loading (full pom also attached):
>>>>       <dependency>
>>>>               <groupId>org.apache.camel</groupId>
>>>>               <artifactId>camel-core</artifactId>
>>>>               <version>2.8.0</version>
>>>>       </dependency>
>>>>       <dependency>
>>>>               <groupId>org.apache.camel</groupId>
>>>>               <artifactId>camel-spring</artifactId>
>>>>               <version>2.8.0</version>
>>>>       </dependency>
>>>>
>>>> I am loading the core&  spring, do I need something beyond that?
>>>>
>>>> Thanks.
>>>>
>>>> http://camel.465427.n5.nabble.com/file/n4741481/pom.xml pom.xml
>>>>
>>>> --
>>>> View this message in context:
>>>>
>>> http://camel.465427.n5.nabble.com/Embedded-Broker-Trying-to-Load-Camel-tp4739257p4741481.html
>>>> Sent from the Camel - Users mailing list archive at Nabble.com.
>>>>
>>>
>>>
>>> ------------------------------------------------------------------------
>>> If you reply to this email, your message will be added to the
>>> discussion below:
>>> http://camel.465427.n5.nabble.com/Embedded-Broker-Trying-to-Load-Camel-tp4739257p4741501.html
>>>
>>> To unsubscribe from Embedded Broker, Trying to Load Camel, click here
>>> <http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4739257&code=c3RldmVAc3Vid2VzdC5jb218NDczOTI1N3wtNDYwNDg3MzUz>.
>>>
>>
>>
>>
>> --
>> View this message in context: http://camel.465427.n5.nabble.com/Embedded-Broker-Trying-to-Load-Camel-tp4739257p4741586.html
>> Sent from the Camel - Users mailing list archive at Nabble.com.
>


-- 
Willem
----------------------------------
FuseSource
Web: http://www.fusesource.com
Blog:    http://willemjiang.blogspot.com (English)
          http://jnn.javaeye.com (Chinese)
Twitter: willemjiang
Weibo: willemjiang

Mime
View raw message