camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Running multiple versions of Camel concurrently
Date Thu, 25 Aug 2011 12:47:43 GMT
Yes, you are right osgi should support for it,
I just found a defect of camel FactoryFinder which can't locate a right 
version of Factory.
So I filled a JIRA[1] for it.
[1]https://issues.apache.org/jira/browse/CAMEL-4380

On 8/25/11 6:21 PM, sebastien.petrucci wrote:
> Hello,
>
> I listed a number of camel imports in my bundle manifest:
>
> *
>
> Import-Package*: org.osgi.framework;*version*="1.3.0",
>
> org.apache.camel;*version*="[2.9,3)",
> [...]
>
> But, in theory, is this supposed to work ?
>
> Regards,
> Sebastien.
>
>
> 2011/8/25 Willem.Jiang [via Camel]<
> ml-node+4733830-2109179769-145309@n5.nabble.com>
>
>> Hi,
>>
>> It looks like the camel-core load the wrong version of strategy.factory.
>>
>> How did specify your route to use Camel 2.8 or Camel 2.9 ?
>>
>>
>> On 8/25/11 4:05 PM, sebastien.petrucci wrote:
>>
>>> Hi,
>>>
>>> I started to dig into the OSGi world. That's really interesting for a
>> number
>>> of reasons.
>>> One of the goals for me is to figure out how to run *concurrently*
>> multiple
>>> Camel contexts with different versions of Camel.
>>> Therefore, I picked up Karaf, Camel 2.8 and a snapshot of Camel 2.9.
>>> I created 2 OSGi bundles implementing a simple flow (using blueprint) and
>>
>>> deployed everything.
>>> The flow using Camel 2.8 works fine.
>>> The flow using Camel 2.9 fails to start with the following error:
>>>
>>>
>>>
>>> I'm still a newbie on the OSGi topic but I was wondering if it would even
>>
>>> work at all, considering that multiple Camel implementations would
>> register
>>> the blueprint namespace handler ... or is this already addressed ?
>>>
>>> Regards,
>>> Sebastien.
>>>
>>> --
>>> View this message in context:
>> http://camel.465427.n5.nabble.com/Running-multiple-versions-of-Camel-concurrently-tp4733518p4733518.html
>>> Sent from the Camel - Users mailing list archive at Nabble.com.
>>>
>>
>>
>> --
>> Willem
>> ----------------------------------
>> FuseSource
>> Web: http://www.fusesource.com
>> Blog:    http://willemjiang.blogspot.com (English)
>>            http://jnn.javaeye.com (Chinese)
>> Twitter: willemjiang
>> Weibo: willemjiang
>>
>>
>> ------------------------------
>>   If you reply to this email, your message will be added to the discussion
>> below:
>>
>> http://camel.465427.n5.nabble.com/Running-multiple-versions-of-Camel-concurrently-tp4733518p4733830.html
>> To unsubscribe from Running multiple versions of Camel concurrently, click
>> here<http://camel.465427.n5.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=4733518&code=c2ViYXN0aWVuLnBldHJ1Y2NpQGdtYWlsLmNvbXw0NzMzNTE4fDMzMTgxNzA0Ng==>.
>>
>>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/Running-multiple-versions-of-Camel-concurrently-tp4733518p4733914.html
> Sent from the Camel - Users mailing list archive at Nabble.com.


-- 
Willem
----------------------------------
FuseSource
Web: http://www.fusesource.com
Blog:    http://willemjiang.blogspot.com (English)
          http://jnn.javaeye.com (Chinese)
Twitter: willemjiang
Weibo: willemjiang

Mime
View raw message