camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tereza Nedelescu <tnedele...@tagged.com>
Subject Re: Camel-nagios comes with older version of JsendNSCA - 1.3.1
Date Thu, 18 Aug 2011 09:24:58 GMT
    The reason why I wanted to switch to version 2.0.1 is because when
running the following code

  <bean id="nSettings" class="com.googlecode.jsendnsca.core.NagiosSettings"
>
      <property name="encryptor" ref="TripleDES" /> 
      <property name="password" value="secret" />
  </bean>

with 1.3.1 I am getting the following error: 

SEVERE: Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'nSettings' defined in ServletContext resource
[/WEB-INF/applicationContext.xml]: Error setting property values; nested
exception is org.springframework.beans.NotWritablePropertyException: Invalid
property 'encryptor' of bean class
[com.googlecode.jsendnsca.core.NagiosSettings]: Bean property 'encryptor' is
not writable or has an invalid setter method. Does the parameter type of the
setter match the return type of the getter?

Is there a way to get around this error while using version 1.3.1 ? 

Thank you,
Tereza




--
View this message in context: http://camel.465427.n5.nabble.com/Camel-nagios-comes-with-older-version-of-JsendNSCA-1-3-1-tp4711112p4711450.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message