camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: ServiceMix 4.3.1 and Camel 2.8-SNAPSHOT
Date Wed, 06 Jul 2011 13:20:57 GMT
Hi Laurentiu,

we're preparing to be able to release very soon when Camel 2.8.0 is out.

Regards
JB

On 07/06/2011 03:18 PM, Laurentiu Trica wrote:
> Hi,
>
> Thanks for the answers.
> Do you have any idea when ServiceMix 4.4 will be released?
>
> Regards,
> Laurentiu
>
> On Wed, Jul 6, 2011 at 4:11 PM, Freeman Fang<freeman.fang@gmail.com>  wrote:
>
>> Hi,
>>
>> I don't think simply change camel version in apache-servicemix-4.3.1-fuse-
>> **01-09-camel-features.xml is enough, a lot of other bundle versions need
>> upgrade too, but it's very hard to do it manually.
>>
>> As next Servciemix 4.4 release will use camel 2.8, so the most simple way I
>> can come up with is you change the camel version(2.8-SNAPSHOT) used in
>> servicemix4 nmr project and build nmr and features, which will generate a
>> servicemix 4.4 snapshot for you.
>>
>> Btw, we should use slf4j from OPS4J Pax Logging bundle so you needn't
>> install slf4j bundle yourself.
>>
>> Freeman
>>
>> On 2011-7-6, at 下午4:02, Laurentiu Trica wrote:
>>
>>   Hi,
>>>
>>> a. Stack trace:
>>> org.osgi.framework.**BundleException: The activator
>>> org.apache.camel.impl.osgi.**Activator for bundle
>>> org.apache.camel.camel-core
>>> is invalid
>>> at
>>> org.eclipse.osgi.framework.**internal.core.AbstractBundle.**
>>> loadBundleActivator(**AbstractBundle.java:156)[osgi-**
>>> 3.6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.framework.**internal.core.**BundleContextImpl.start(**
>>> BundleContextImpl.java:751)[**osgi-3.6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.framework.**internal.core.BundleHost.**
>>> startWorker(BundleHost.java:**370)[osgi-3.6.0.v20100517.jar:**]
>>> at
>>> org.eclipse.osgi.framework.**internal.core.AbstractBundle.**
>>> start(AbstractBundle.java:284)**[osgi-3.6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.framework.**internal.core.AbstractBundle.**
>>> start(AbstractBundle.java:276)**[osgi-3.6.0.v20100517.jar:]
>>> at
>>> org.apache.karaf.shell.osgi.**StartBundle.doExecute(**
>>> StartBundle.java:29)[17:org.**apache.karaf.shell.osgi:2.1.4.**fuse-00-09]
>>> at
>>> org.apache.karaf.shell.osgi.**BundlesCommand.doExecute(**
>>> BundlesCommand.java:49)[17:**org.apache.karaf.shell.osgi:2.**
>>> 1.4.fuse-00-09]
>>> at
>>> org.apache.karaf.shell.**console.OsgiCommandSupport.**
>>> execute(OsgiCommandSupport.**java:38)[9:org.apache.karaf.**
>>> shell.console:2.1.4.fuse-00-**09]
>>> at
>>> org.apache.felix.gogo.**commands.basic.**AbstractCommand.execute(**
>>> AbstractCommand.java:35)[9:**org.apache.karaf.shell.**
>>> console:2.1.4.fuse-00-09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.CommandProxy.execute(**
>>> CommandProxy.java:50)[9:org.**apache.karaf.shell.console:2.**
>>> 1.4.fuse-00-09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.Closure.execute(Closure.**
>>> java:229)[9:org.apache.karaf.**shell.console:2.1.4.fuse-00-**09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.Closure.**
>>> executeStatement(Closure.java:**162)[9:org.apache.karaf.shell.**
>>> console:2.1.4.fuse-00-09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.Pipe.run(Pipe.java:101)[**
>>> 9:org.apache.karaf.shell.**console:2.1.4.fuse-00-09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.Closure.execute(Closure.**
>>> java:79)[9:org.apache.karaf.**shell.console:2.1.4.fuse-00-**09]
>>> at
>>> org.apache.felix.gogo.runtime.**shell.CommandSessionImpl.**
>>> execute(CommandSessionImpl.**java:71)[9:org.apache.karaf.**
>>> shell.console:2.1.4.fuse-00-**09]
>>> at
>>> org.apache.karaf.shell.**console.jline.Console.run(**
>>> Console.java:170)[9:org.**apache.karaf.shell.console:2.**1.4.fuse-00-09]
>>> at java.lang.Thread.run(Thread.**java:662)[:1.6.0_24]
>>> Caused by: java.lang.**NoClassDefFoundError: org/apache/log4j/LogManager
>>> at org.slf4j.impl.**Log4jLoggerFactory.getLogger(**
>>> Log4jLoggerFactory.java:73)
>>> at
>>> org.slf4j.LoggerFactory.**getLogger(LoggerFactory.java:**
>>> 242)[3:org.ops4j.pax.logging.**pax-logging-api:1.5.3]
>>> at
>>> org.slf4j.LoggerFactory.**getLogger(LoggerFactory.java:**
>>> 254)[3:org.ops4j.pax.logging.**pax-logging-api:1.5.3]
>>> at org.apache.camel.impl.osgi.**Activator.<clinit>(Activator.**java:77)
>>> at sun.reflect.**NativeConstructorAccessorImpl.**newInstance0(Native
>>> Method)[:1.6.0_24]
>>> at
>>> sun.reflect.**NativeConstructorAccessorImpl.**newInstance(**
>>> NativeConstructorAccessorImpl.**java:39)[:1.6.0_24]
>>> at
>>> sun.reflect.**DelegatingConstructorAccessorI**mpl.newInstance(**
>>> DelegatingConstructorAccessorI**mpl.java:27)[:1.6.0_24]
>>> at
>>> java.lang.reflect.Constructor.**newInstance(Constructor.java:**
>>> 513)[:1.6.0_24]
>>> at java.lang.Class.newInstance0(**Class.java:355)[:1.6.0_24]
>>> at java.lang.Class.newInstance(**Class.java:308)[:1.6.0_24]
>>> at
>>> org.eclipse.osgi.framework.**internal.core.AbstractBundle.**
>>> loadBundleActivator(**AbstractBundle.java:151)[osgi-**
>>> 3.6.0.v20100517.jar:]
>>> ... 16 more
>>> Caused by: java.lang.**ClassNotFoundException:
>>> org.apache.log4j.LogManager
>>> at
>>> org.eclipse.osgi.internal.**loader.BundleLoader.**findClassInternal(**
>>> BundleLoader.java:460)[osgi-3.**6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.internal.**loader.BundleLoader.findClass(**
>>> BundleLoader.java:422)[osgi-3.**6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.internal.**loader.BundleLoader.findClass(**
>>> BundleLoader.java:410)[osgi-3.**6.0.v20100517.jar:]
>>> at
>>> org.eclipse.osgi.internal.**baseadaptor.**DefaultClassLoader.loadClass(**
>>> DefaultClassLoader.java:107)[**osgi-3.6.0.v20100517.jar:]
>>> at java.lang.ClassLoader.**loadClass(ClassLoader.java:**248)[:1.6.0_24]
>>> ... 27 more
>>>
>>> b. I made the following steps:
>>> - I modified the
>>> ServicemixFolder/system/org/**apache/servicemix/apache-**
>>> servicemix/4.3.1-fuse-01-09/**apache-servicemix-4.3.1-fuse-**
>>> 01-09-camel-features.xml
>>> to use Camel 2.8-SNAPSHOT
>>> - Added Camel snapshots repo (
>>> https://repository.apache.org/**content/repositories/snapshots<https://repository.apache.org/content/repositories/snapshots>
>>> **) in here:
>>> ServicemixFolder/etc/org.**ops4j.pax.url.mvn.cfg
>>> - installed osgi:install mvn:org.slf4j/slf4j-api/1.6.1
>>> - installed osgi:install mvn:org.slf4j/slf4j-log4j12/1.**6.1 - these libs
>>> are
>>> required by Camel - as far as I've seen.
>>>
>>> Seems the problem is somewhere about logging...
>>>
>>> On Tue, Jul 5, 2011 at 11:34 PM, Ashwin Karpe<akarpe@fusesource.com>
>>> wrote:
>>>
>>>   Hi,
>>>>
>>>> Can you provide more details such as
>>>>
>>>>     a>  Stack Trace
>>>>     b>  How you went about installing the camel-core...?
>>>>
>>>> Thanks and Regards,
>>>>
>>>> Ashwin...
>>>>
>>>> -----
>>>> ------------------------------**---------------------------
>>>> Ashwin Karpe
>>>> Apache Camel Committer&  Sr Principal Consultant
>>>> FUSESource (a Progress Software Corporation subsidiary)
>>>> http://fusesource.com
>>>>
>>>> Blog: http://opensourceknowledge.**blogspot.com<http://opensourceknowledge.blogspot.com>
>>>> ------------------------------**---------------------------
>>>> --
>>>> View this message in context:
>>>> http://camel.465427.n5.nabble.**com/ServiceMix-4-3-1-and-**
>>>> Camel-2-8-SNAPSHOT-**tp4553864p4554656.html<http://camel.465427.n5.nabble.com/ServiceMix-4-3-1-and-Camel-2-8-SNAPSHOT-tp4553864p4554656.html>
>>>> Sent from the Camel - Users mailing list archive at Nabble.com.
>>>>
>>>>
>>>
>>> ------------------------------**---------------
>> Freeman Fang
>>
>> FuseSource
>> Email:ffang@fusesource.com
>> Web: fusesource.com
>> Twitter: freemanfang
>> Blog: http://freemanfang.blogspot.**com<http://freemanfang.blogspot.com>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message