camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lorenz, Stefan" <Stefan.Lor...@htw-aalen.de>
Subject Missing Constraint: org.springframework.osgi.context
Date Wed, 15 Jun 2011 11:33:07 GMT
Hi,

I just tried to upgrade from Camel 2.5 to 2.7.2.
I use Camel in an Equinox OSGI environment.

But now I get the following error:

!ENTRY org.apache.camel.camel-spring 4 0 2011-06-15 13:14:53.341
!MESSAGE
!STACK 0
org.osgi.framework.BundleException: The bundle "org.apache.camel.camel-spring_2.7.2 [23]"
could not be resolved. Reason: Missing Constraint: Import-Package: org.springframework.osgi.context;
version="[1.2.0,2.0.0)"

I'm not sure what I'm doing wrong. But it seems that the libraries from springframework are
not including the missing package...
Do I have to get them manually?

Thx & regards
Stefan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message