camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gert Vanthienen <gert.vanthie...@gmail.com>
Subject Re: Missing Constraint: org.springframework.osgi.context
Date Wed, 15 Jun 2011 12:02:24 GMT
Stefan,

That package is part of spring-dm - those are a separate set of
bundles (spring-osgi-core, spring-osgi-io, ...) that need to be
installed next to the default Spring libraries that you probably have
(things like spring-bean, ...).

Regards,

Gert Vanthienen
------------------------
FuseSource
Web: http://fusesource.com
Blog: http://gertvanthienen.blogspot.com/



On Wed, Jun 15, 2011 at 1:33 PM, Lorenz, Stefan
<Stefan.Lorenz@htw-aalen.de> wrote:
> Hi,
>
> I just tried to upgrade from Camel 2.5 to 2.7.2.
> I use Camel in an Equinox OSGI environment.
>
> But now I get the following error:
>
> !ENTRY org.apache.camel.camel-spring 4 0 2011-06-15 13:14:53.341
> !MESSAGE
> !STACK 0
> org.osgi.framework.BundleException: The bundle "org.apache.camel.camel-spring_2.7.2 [23]"
could not be resolved. Reason: Missing Constraint: Import-Package: org.springframework.osgi.context;
version="[1.2.0,2.0.0)"
>
> I'm not sure what I'm doing wrong. But it seems that the libraries from springframework
are not including the missing package...
> Do I have to get them manually?
>
> Thx & regards
> Stefan
>

Mime
View raw message