camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: maven plugin
Date Thu, 07 Apr 2011 07:51:01 GMT
Hi

What version of Camel are you using?

I have created a ticket to remove the DOT stuff
https://issues.apache.org/jira/browse/CAMEL-3841



On Mon, Apr 4, 2011 at 4:53 PM, Mark Webb <elihusmails@gmail.com> wrote:
> I am testing some routes and would like to create some sample routes
> to "play" with.  I am using maven to create these projects with the
> following command:
>
> mvn archetype:create -DgroupId=a.b.c.d -DartifactId=MyRouter
> -DarchetypeArtifactId=camel-router -DarchetypeGroupId=org.apache.camel
>
> This command works fine, I can run the command "mvn package", and that
> runs fine.  I then try and run the command "mvn camel:run" and the
> command hangs, and this is the last line printed out:
>
> Apr 4, 2011 9:47:02 AM org.apache.camel.spring.Main generateDot
> INFO: Generating DOT file for routes:
> C:\temp\MyRouter\target/site/cameldoc for:
> org.apache.camel.spring.SpringCamelContext@622209db with name:
> camelContext
>
> Before running the command, I added in the following lines to the pom.xml file:
>
> <configuration>
>        <useDot>false</useDot>
> </configuration>
>
> I even tried to specify the path to dot.exe and got the same results.
> So is there any way I can run the camel route without running "dot"
> from maven?
>
> Thanks,
> Mark
>



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
CamelOne 2011: http://fusesource.com/camelone2011/
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message