camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Issues with running camel-example-osgi on Eclipse Equinox
Date Tue, 29 Mar 2011 07:27:59 GMT
How about the bundle 23, 24 ?
Can you take a look at them ?

Willem

On 3/29/11 2:15 PM, Владимир Большуткин wrote:
> Hello,
>
> I have issues on using Camel in Eclipse Equinox (my goal is to create
> Eclipse plugin with Camel support). First of all, I'm trying to run
> camel-example-osgi. I managed to run it under Apache Karaf (with
> Equinox set as framework in config) as there were good tutorials, but
> not bare Eclipse Equinox.
>
> I ran bare Eclipse Equinox, and installed all necessary dependencies
> one by one (using pax-url-mvn bundle)
>
> osgi>  ss
> Framework is launched.
> id	State       Bundle
> 0	ACTIVE      org.eclipse.osgi_3.6.2.R36x_v20110210
> 1	ACTIVE      org.ops4j.pax.url.mvn_1.2.3
> 2	ACTIVE      org.apache.camel.camel-core_2.7.0
> 3	ACTIVE      org.springframework.core_3.0.5.RELEASE
> 4	ACTIVE      org.apache.camel.camel-context_2.7.0
> 6	ACTIVE      org.apache.camel.camel-spring_2.7.0
> 7	ACTIVE      com.springsource.net.sf.cglib_2.2.0
> 8	ACTIVE      com.springsource.org.aopalliance_1.0.0
> 9	ACTIVE      commons-management_1.0.0
> 10	ACTIVE      org.springframework.aop_3.0.5.RELEASE
> 11	ACTIVE      org.springframework.asm_3.0.5.RELEASE
> 12	ACTIVE      org.springframework.beans_3.0.5.RELEASE
> 13	ACTIVE      org.springframework.context_3.0.5.RELEASE
> 15	ACTIVE      org.springframework.expression_3.0.5.RELEASE
> 16	ACTIVE      org.springframework.osgi.core_1.2.1
> 17	ACTIVE      org.springframework.osgi.io_1.2.1
> 18	ACTIVE      org.springframework.transaction_3.0.5.RELEASE
> 21	ACTIVE      com.springsource.org.apache.commons.logging_1.1.1
> 22	ACTIVE      org.apache.camel.camel-example-osgi_2.7.0
> 25	ACTIVE      slf4j.api_1.6.1
> 	            Fragments=26
> 26	RESOLVED    slf4j.simple_1.6.1
> 	            Master=25
>
> 26th bundle must not be started as it is a Fragment.
>
> The only output were two lines on activating camel-core bundle:
> 0 [OSGi Console] INFO org.apache.camel.impl.osgi.Activator - Camel
> activator starting
> 48 [OSGi Console] INFO org.apache.camel.impl.osgi.Activator - Camel
> activator started
>
> Seems, everything is active, but there's no timed messages from Camel.
> What is the right way to launch Camel context?
>
> I also tried to use Camel 2.5.0 and Spring 3.0.4.RELEASE but got the
> same situation.
>
> Please, could you explain where can be my fault?
>
> Thanks,
> Vladimir.
>


-- 
Willem
----------------------------------
FuseSource
Web: http://www.fusesource.com
Blog:    http://willemjiang.blogspot.com (English)
          http://jnn.javaeye.com (Chinese)
Twitter: willemjiang

Mime
View raw message