camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: JBoss 5.1.0 -> 6.0.0.Final (Camel Issues)
Date Sun, 23 Jan 2011 08:45:17 GMT
On Sat, Jan 22, 2011 at 7:47 PM, Phobos <sm0k3yuk@gmail.com> wrote:
>
>
> Hi,
>
> I have a project packaged into an EAR that contains multiple EJB modules and
> a WAR module that utilises Camel 2.5.0 (configured via Spring with correct
> config of jbossResolver etc). The project works perfectly when the EAR is
> deployed into JBoss 5.1.0 but doesn't quite work at all when deployed to a
> new JBoss 6.0.0 container.
>
> When deployed into JBoss 6.0.0. all EJBs are started correctly but when it
> comes to deploying the contained WAR no error messages are displayed and I
> just get the following log entry;
>
> 18:44:04,096 INFO  [org.jboss.web.tomcat.service.deployers.TomcatDeployment]
> deploy, ctxPath=/<CONTEXT ROOT NAME>
>
> Has anyone got Camel 2.5.0 working with JBoss 6/JEE6?
>

Hmmm the JBoss people may have yet again change classloading and
whatnot in their server.
But even with the jboss-vfs JARs which camel-jboss use it may not work
as you report.

Have you tried to look for never versions of those jboss-vfs JARs that
camel-jboss uses?
Maybe there are some versions which works with JBoss 6



> Thanks
> --
> View this message in context: http://camel.465427.n5.nabble.com/JBoss-5-1-0-6-0-0-Final-Camel-Issues-tp3353086p3353086.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message