camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marco Zapletal <marco.zaple...@gmail.com>
Subject Re: camel-cxf: exception when parsing cxf:schemaLocation element | 2.6-SNAPSHOT maven problem
Date Thu, 18 Nov 2010 09:42:09 GMT

Hi Willem,

thanks for the solution. For the moment, I had to step back to 
2.5/2.2.11, but I will try your fix next week.


On 17.11.2010 14:32, Willem Jiang wrote:
> Hi Marco,
>
> I played with your test case and found something interesting, The issue
> is related to CXF bus initiation.
> I managed to run the test with CXF 2.3.0 by changing the
> camel-conf-test.xml like this
>
> <!-- import resource="classpath:META-INF/cxf/cxf.xml" /-->
> <import resource="classpath:META-INF/cxf/cxf-extension-soap.xml" />
> <import resource="classpath:META-INF/cxf/cxf-extension-http-jetty.xml" />
>
> It looks like cxf.xml can't load the bus with the lazy-init components,
> if I remove the cxf.xml part, CXFSprintBusFactory will create the
> default bus itself, and it just work around the issue.
>
> I will dig bus code deeper to find if there is some better solution.
> BTW, current work around should work for CXF 2.2.x and CXF 2.3.x at the
> same time.
>
> On 11/16/10 12:11 AM, Marco Zapletal wrote:
>> thats true ;-) so please find attached a simple test case, which
>> demonstrates the error. If you switch the CXF version in the pom from
>> 2.3.0 back to 2.2.11 it works.
>>
>> thanks,
>> marco
>>
>>
>> On 14.11.2010 09:23, Willem Jiang wrote:
>>> I can't see any strange CXF bus setting from your configuration,
>>> So there must be some change in CXF 2.3.0 cause this issue.
>>> It's hard to trace the error without a test case :(
>>>
>>>
>>> On 11/12/10 7:21 PM, Marco Zapletal wrote:
>>>> sure. this is a condensed version of one of my tests
>>>>
>>>> http://pastebin.com/3u7q84ES
>>>>
>>>> this is the camel-config.xml file.
>>>>
>>>> http://pastebin.com/1UhDV7rw
>>>>
>>>> It is referenced from my JunitSpringConfig, which is a Spring
>>>> JavaConfig
>>>> @Configuration instance.
>>>>
>>>> I am using the latest snapshots of Camel 2.6-SNAPSHOT of CXF 2.3. Jetty
>>>> 7 is resolved as a dependency.
>>>>
>>>> thanks,
>>>> marco
>>>>
>>>>
>>>>
>>>> Am 12.11.2010 11:19, schrieb Willem Jiang:
>>>>> Can I have a look at your Junit tests code?
>>>>> I just want to asked the same thing in the CXF mailing list.
>>>>>
>>>>>
>>>>> On 11/12/10 6:05 PM, Marco Zapletal wrote:
>>>>>> Just something I wanted to add. The patch is working and when
>>>>>> deploying
>>>>>> my camel/cxf app to tomcat everything goes fine (the services are
>>>>>> deployed and the schemas are appropriately referenced).
>>>>>>
>>>>>> however, when running my Junit tests with CXF 2.6-SNAPSHOT and CXF
>>>>>> 2.3.0, I am getting NPEs as described on the cxf list
>>>>>>
>>>>>> http://cxf.547215.n5.nabble.com/2-3-0-NPE-in-ClientImpl-setupInterceptorChain-tp3260303p3260303.html
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> this problem, however, seems quite strange and I do not know how
to
>>>>>> start searching for the cause.
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> Am 12.11.2010 01:23, schrieb Willem Jiang:
>>>>>>>
>>>>>>> Thanks for your report, it good to know the patch is working
:)
>>>>>>>
>>>>>>> On 11/11/10 10:05 PM, Marco Zapletal wrote:
>>>>>>>> Hi,
>>>>>>>>
>>>>>>>> using 2.6-SNAPSHOT together with CXF 2.3.0 seems to work
fine.
>>>>>>>> thanks.
>>>>>>>>
>>>>>>>>
>>>>>>>> On 10.11.2010 09:11, Willem Jiang wrote:
>>>>>>>>> Hi,
>>>>>>>>>
>>>>>>>>> Current camel-cxf is using CXF 2.3.0. It should be better
if you
>>>>>>>>> try to
>>>>>>>>> run the test with CXF 2.3.0.
>>>>>>>>> If you can't use CXF 2.3.0, please make sure you are
using CXF
>>>>>>>>> 2.2.11,
>>>>>>>>> and there is no other version of CXF in you classpath.
>>>>>>>>>
>>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>>
>>
>
>


Mime
View raw message