camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ɓukasz Dywicki <l...@code-house.org>
Subject ServiceMix IDE update site available
Date Tue, 26 Oct 2010 22:00:43 GMT
Hi All,

I've published update site with statis tooling for Camel/ActiveMQ/ServiceMix
just say your eclipse to install it from:

http://servicemix.pl/ide/update/dev/

 

Very short user guide? To get tooling in XML use correct schema namespace
and linked location.

 

For ServiceMix:

http://servicemix.apache.org/schema/

 

For camel 1.x

http://activemq.apache.org/schema/camel/spring

http://activemq.apache.org/schema/camel/spring/integration

http://activemq.apache.org/schema/camel/rest

http://activemq.apache.org/schema/camel/osgi

http://activemq.apache.org/schema/camel/cxf

 

For camel 2.x

http://camel.apache.org/schema/spring

http://camel.apache.org/schema/spring/integration

http://camel.apache.org/schema/spring-security

http://camel.apache.org/schema/web

http://camel.apache.org/schema/osgi

http://camel.apache.org/schema/blueprint

 

For ActiveMQ:

http://activemq.apache.org/schema/core

http://activemq.apache.org/schema/jpa-store

http://activemq.apache.org/schema/ra

 

For these who use FUSE releases - they're also supported - use same schema
location like for Apache release with fuse version and classifier, for
example:

....

xmlns:rest="http://camel.apache.org/schema/rest"

xsi:schemaLocation="http://camel.apache.org/schema/rest/camel-rest-1.6.2.2-f
use.xsd"

 

Only versioned schema locations are currently supported.

 

Short FAQ

1. What is requirements

- Plugin should work with both Eclispe Helios and Galileo. The only one
requirement at this moment is M2Eclipse in version 0.9.4 or above to use
archetype catalogs.

 

If you have any questions - feel free to ask.

 

Best regards,

Lukasz :)

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message