camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Webb <elihusma...@gmail.com>
Subject Re: problem using MINA endpoint
Date Mon, 27 Sep 2010 16:15:36 GMT
that was the problem.  I was still using ActiveMQ 5.3.2 which is using
Camel 2.2.0.

Thanks


On Mon, Sep 27, 2010 at 11:54 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
> On Mon, Sep 27, 2010 at 5:47 PM, Mark Webb <elihusmails@gmail.com> wrote:
>> I am working to set up Camel to receive data on a MINA endpoint.  I
>> have the following statement in my camel XML file:
>>
>>        <route>
>>                <from uri="mina:tcp://localhost:5555?textline=true"/>
>>                <to uri="jms:topic:mina.topic" />
>>        </route>
>>
>> When I start up ActiveMQ, I get the following:
>>
>> Failed to execute main task. Reason: java.lang.NoSuchMethodError:
>> org.apache.camel.CamelContext.getExecutorServiceStrategy()Lorg/apache/camel/spi/ExecutorServiceStrategy;
>>
>>
>>
>> Where am I going wrong?  Is this the proper way to set this up, or am
>> I doing something else wrong?
>>
>
> You may have mixed versions of Camel in the classpath. Make sure they
> are all from the same version.
>
>
>> Thanks,
>> Mark
>>
>
>
>
> --
> Claus Ibsen
> Apache Camel Committer
>
> Author of Camel in Action: http://www.manning.com/ibsen/
> Open Source Integration: http://fusesource.com
> Blog: http://davsclaus.blogspot.com/
> Twitter: http://twitter.com/davsclaus
>

Mime
View raw message