camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: XMPP + Smack
Date Sat, 18 Sep 2010 07:03:36 GMT
Hi

These are the jars from the 2.5-SNAPSHOT. You need to use the ones
which listed as compile.

[INFO] The following files have been resolved:
[INFO]    aopalliance:aopalliance:jar:1.0:test
[INFO]    commons-logging:commons-logging:jar:1.1.1:test
[INFO]    commons-logging:commons-logging-api:jar:1.1:compile
[INFO]    junit:junit:jar:4.8.1:test
[INFO]    log4j:log4j:jar:1.2.16:test
[INFO]    org.apache.camel:camel-core:jar:2.5-SNAPSHOT:compile
[INFO]    org.apache.camel:camel-spring:jar:2.5-SNAPSHOT:test
[INFO]    org.apache.camel:camel-test:jar:2.5-SNAPSHOT:test
[INFO]    org.fusesource.commonman:commons-management:jar:1.0:compile
[INFO]    org.igniterealtime.smack:smack:jar:3.1.0:compile
[INFO]    org.igniterealtime.smack:smackx:jar:3.1.0:compile
[INFO]    org.springframework:spring-aop:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-asm:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-beans:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-context:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-core:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-expression:jar:3.0.4.RELEASE:test
[INFO]    org.springframework:spring-tx:jar:3.0.4.RELEASE:test


On Sat, Sep 18, 2010 at 9:00 AM, Donald Whytock <dwhytock@gmail.com> wrote:
> Okay, the .jars I'm using at the moment are:
>
> camel-core-2.4.0.jar
> javaee.jar
> commons-management-1.0.jar
> commons-logging-1.1.1.jar
> camel-xmpp-2.4.0.jar
> smack-3.0.4.jar
> smackx-3.0.4.jar
> jaxb-api-2.1.jar
> jaxb-impl-2.1.12.jar
>
> When I try to listen for XMPP messages I get only one property set on
> the exchange and no headers in either the in or the out messages.  My
> endpoint is
>
> xmpp://localhost/?user=bot&password=botpass
>
> exchange.getProperties().keySet().toString() gives me
>
> [CamelBinding]
>
> exchange.getIn().getHeaders().keySet().toString() gives me
>
> []
>
> Same results for an ISP's server as with a localhost server.  Am I
> missing a .jar?  I know I'm going kinda minimalist, but I thought I
> had everything I needed.
>
> Don
>
> On Sat, Sep 18, 2010 at 2:25 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
>> On Sat, Sep 18, 2010 at 5:02 AM, Donald Whytock <dwhytock@gmail.com> wrote:
>>> Hi all...
>>>
>>> Trying to work with the XMPP component, I find I needed the following .jars:
>>>
>>> smack-3.0.4.jar
>>> smackx-3.0.4.jar
>>>
>>> Are these the correct versions to use with Camel 2.4.0?  Will these
>>
>> Use maven and it will download all the needed files for you.
>> If not you can check the parent/pom.xml file in Camel source which
>> lists the versions used at that release time
>> https://svn.apache.org/repos/asf/camel/tags/camel-2.4.0/parent/pom.xml
>>
>> But you can use any compliant jar file as long as it doesn't break :)
>> So if there is a 3.0.5 jar that works as well then you can use that.
>>
>> Looks like 2.4.0 uses
>>    <smack-version>3.1.0</smack-version>
>>
>>
>>
>>> eventually be included with the Camel download?
>>>
>>
>> No, the download will get too big if Camel included all the .jars for
>> all the components.
>>
>>
>> If you use maven or osgi then they can automatic download the jars for you.
>>
>>
>>> Don
>>>
>>
>>
>>
>> --
>> Claus Ibsen
>> Apache Camel Committer
>>
>> Author of Camel in Action: http://www.manning.com/ibsen/
>> Open Source Integration: http://fusesource.com
>> Blog: http://davsclaus.blogspot.com/
>> Twitter: http://twitter.com/davsclaus
>>
>



-- 
Claus Ibsen
Apache Camel Committer

Author of Camel in Action: http://www.manning.com/ibsen/
Open Source Integration: http://fusesource.com
Blog: http://davsclaus.blogspot.com/
Twitter: http://twitter.com/davsclaus

Mime
View raw message