camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bryan <brya...@gmail.com>
Subject Re: File can't be moved or deleted on Windows
Date Fri, 02 Jul 2010 07:27:58 GMT

I just tested this on Windows XP 32-bit with JDK 1.6.0_20 32-bit, and have
this same issue. I'm not sure what you mean by the configuration of the file
endpoint URI? I have my entire camel spring context shown. The .camel
directory is being created successfully, but the file is never moved there
when using a split. Again, the file is moved fine when not using a split, so
this doesn't seem related to file permissions or such.

My suspicion is that the split code is not closing the file properly on
Windows, and thus it cannot be moved. I tried deleting the file from the
Windows command line after processing and get a "file in use" error. I also
tried adding a delay of 10 sec at the end of the route, but this didn't
solve anything.

(A side note, I also tested this on my Mac, and this problem does not occur,
so it is Windows-specific.)

-- 
View this message in context: http://camel.465427.n5.nabble.com/File-can-t-be-moved-or-deleted-on-Windows-tp512484p512559.html
Sent from the Camel - Users mailing list archive at Nabble.com.

Mime
View raw message