camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lekkie <lekkie.ay...@gmail.com>
Subject Re: Missing dependencies: Spring cannot find com.mchange.v2.c3p0
Date Fri, 12 Feb 2010 15:07:11 GMT

I had to edit the manifest and export the packages I needed.


willem.jiang wrote:
> 
> Hi,
> 
> How did you resolve that issue?
> Can you share it ?
> It could be useful if other user hit the same issue as you.
> 
> Willem
> 
> lekkie wrote:
>> Resolved. Thanks
>> 
>> 
>> 
>> lekkie wrote:
>>> I am trying to use com.mchange.v2.c3p0.ComboPooledDataSource in my
>>> camelcontext to create datasource. See below:
>>>
>>> <bean id="kimonoDataSource"
>>> class="com.mchange.v2.c3p0.ComboPooledDataSource"
>>> destroy-method="close">
>>>         <property
>>> name="driverClass"><value>${jdbc.driverClassName}</value></property>
>>> </bean>
>>>
>>> Even though I have included the package in my imported package 
>>>
>>> <Import-Package>com.mchange.v2.c3p0, *</Import-Package>
>>>
>>> and I also have it in my dependencies
>>>
>>> <dependency>
>>> 		<groupId>c3p0</groupId>
>>> 		<artifactId>c3p0</artifactId>
>>> 		<version>0.9.1.2</version>
>>> </dependency>
>>>
>>> whixh I can confirmed was downloaded.
>>>
>>> I also installed it as an OSGi bundle (install mvn:c3p0/c3p0/0.9.1.2)
>>> which was installed and marked as active.
>>>
>>> Each time I want to start my camel application, it still says "The
>>> bundle
>>> could not be resolved. Reason: Missing Constraint: Import-Package:
>>> com.mchange.v2.c3p0; version="0.0.0""
>>>
>>> Please kindly advise.
>>>
>>>
>>>
>> 
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/Missing-dependencies%3A-Spring-cannot-find-com.mchange.v2.c3p0-tp27531961p27564925.html
Sent from the Camel - Users mailing list archive at Nabble.com.


Mime
View raw message