camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: route debugging
Date Mon, 11 Jan 2010 09:06:17 GMT
On Mon, Jan 11, 2010 at 10:03 AM, yaog <yairogen@gmail.com> wrote:
>
> Hi,
>
> I have this rourte:
>
>        <route id="route1">
>                        <from uri="direct:start" />
>                        <to uri="bean:compAImpl" />
>                        <to uri="jms:compB" />
>                        <to uri="bean:compBImpl" />
>                        <to uri="jms:compC" />
>                        <to uri="bean:compCImpl" />
>                </route>
>
>
> compAImpl is activated ok but then it gets stuck and I fail on timeout with
> the jms.
>

That is because you are very likely doing a request/reply messaging
style, eg using InOut MEP.
Send using InOnly to the JMS queue (or use wireTap to tap the message
to the JMS queue).

See this unit test how to
http://svn.apache.org/viewvc?rev=897802&view=rev


> can anyone identify what is wrong?
>
> how do I debug a route that does not work as I think it should? Itried
> adding trace-"true" on the camel context. Didn't help much. endpoint are
> created ok.
>
> Please advise.
>
>
> --
> View this message in context: http://old.nabble.com/route-debugging-tp27107483p27107483.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>
>



-- 
Claus Ibsen
Apache Camel Committer

Author of Camel in Action: http://www.manning.com/ibsen/
Open Source Integration: http://fusesource.com
Blog: http://davsclaus.blogspot.com/
Twitter: http://twitter.com/davsclaus

Mime
View raw message