camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From erh <>
Subject Getting "No getConsumers() available on Producer" on startup
Date Thu, 10 Dec 2009 17:57:36 GMT

I'm having trouble with what seems to be a race condition during Camel
startup, which is causing "No getConsumers() available on Producer" errors
to happen:

No getConsumers()
 available on Producer[direct:coreServerDispatch] for Exchange[Message:

The consumer that tries to send things to this endpoint is added a few
milliseconds earlier, but the consumer for "direct:coreServerDispatch" isn't
added until *after* this error (TuLifecycleStrategy is a subclass of
DelegateLifecycleStrategy that just logs any calls to onServiceAdd()):

Adding service: Consumer on Endpoint[direct:coreServerDispatch]

I've seen other messages about this in the archives that mention things like
turning off JMX
(  I
haven't tried that yet, but I'm wondering why it would make a difference. 
It looks like the issue is that the consumers get started before all the
routes are setup.  Wouldn't that still happen even with JMX off?

I'm using Camel 1.6.2 (release).

Also, it seems there a similar issue with a timer route, where the timer
fires before the processor is ready; the error message in that case is "
java.lang.IllegalStateException: No producer, this processor has not been
started! while processing exchange: Exchange[Message: null]"

View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message