camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lujan99 <luja...@gmail.com>
Subject Re: usign http componente with ssl
Date Mon, 16 Nov 2009 10:09:20 GMT

My test is with ActiveMQ 5.3 / Camel 2.0



willem.jiang wrote:
> 
> Hi
> 
> First which version of Camel are you using?
> I just test the url within HttpsGetTest[1] on the trunk, everything 
> looks good.
> 
> [1]https://svn.apache.org/repos/asf/camel/trunk/components/camel-http/src/test/java/org/apache/camel/component/http/HttpsGetTest.java
> 
> Willem
> 
> lujan99 wrote:
>> I build some test, and I have an error with all site https, example:
>>         <route>
>>           <from
>> uri="timer://foo?fixedRate=true&amp;delay=0&amp;period=30000"/>
>>           <to uri="https://www.google.com/accounts/ServiceLogin"/>
>>           <to uri="file://d:/work/camel"/>
>>         </route>
>> 
>> when I follow this request with ethereal I see:
>> 
>> 192.168.1.99	190.17.124.232	SSLv2	Client Hello
>> 190.17.124.232	192.168.1.99	TLSv1	Server Hello, Certificate, Server Hello
>> Done
>> 192.168.1.99	190.17.124.232	TLSv1	Alert (Level: Fatal, Description:
>> Certificate Unknown)
>> 
>> I can get any result using https, 
>> 
>> how can I fix this issue??
>> 
>> 
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/usign-http-componente-with-ssl-tp26365801p26369458.html
Sent from the Camel - Users mailing list archive at Nabble.com.


Mime
View raw message