camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tide08 <>
Subject Issue with Load and Soak test
Date Tue, 10 Nov 2009 23:10:27 GMT

I am trying to setup load and soak test for my routes but I am running into
issues. Can someone point out what exactly am I doing wrong? 

I am using Camel 2.1-SNAPSHOT and subetha/wiser as smtp for this test, and
since it does not support imap, to consume the messagse. I thought I would
write custom component (wiser://) to read back messages from smtp and there
by get first hand experience in writing custom component :)

I hope I am taking right approach here, if there is better way to do this,
please let me know.

Here is the app route:

 <camel:camelContext id="main">
    <camel:template id="camelTemplate"/>
    <camel:route errorHandlerRef="serviceErrorHandler">
        <camel:from uri="activemq:queue:myqueue"/>
        <camel:to uri="processor1" />
        <camel:to uri="processor2" />
        <camel:to uri="smtp://localhost:2501"/>

Than I add below 2 camel routes in my load test context:
<!-- Pump some data -->
            <camel:from uri="dataset:messageDataSet"/>
            <camel:to uri="activemq:queue:myqueue" />

            <camel:from uri="wiser://dummy" />  
            <camel:to uri="dataset:messageDataSet"/>

Please see attached classes related to wiser component, it has to be polling
endpoint, which polls for messages on wiser and routes those. All the
messages are consumed by WiserConsumer but it does not make it back to
dataset:// but instead go to ErrorHandler. I do not see any errors in the
log and debugging does not help either it just seems like ErrorHandler
intercepts it.

I tried to swap out app route with just simple queue to make sure my dataSet
is configured correctly and it worked. So I guess I have made mistake in
WiserComponent somewhere which I could not locate. 

View this message in context:
Sent from the Camel - Users mailing list archive at

View raw message