camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <>
Subject Re: Problem using a CamelTransportFactory from a junit 4 unit test or together with <context:annotation-config/>
Date Tue, 27 Oct 2009 11:53:16 GMT
Hi Christian,

I just did quick fix for all your issues, please check them out if you 
have time to try the latest camel 2.1-SNAPSHOT.


Christian Schneider wrote:
> Hi Claus,
> I am using Camel 2.0.0 and Spring 2.5.5. I am not sure which exact junit 
> 4 version it is. Have to look at work.
> I do not think that it really is a junit 4 problem. It only seems that 
> when using the new spring test framework that autowiring is activated 
> for the whole spring config.
> I debugged into the problem and think that it has to do with 
> CamelTranportFactory.setActivationNamespaces(Collection<String> ans). It 
> seems to look for an autowiring candidate for
> this setter.
> I have created a jira issue for the problem together with  a sample 
> project:
> Btw. while looking into the issue I found that I had a mix of CXF jars 
> from CXF 2.2.2 and 2.2.4 in my project. This seems to originate from 
> camel-cxf. I have created another issue for this:
> First I thought my first problem had to do with this mix but when I 
> adjusted my pom so only the cxf 2.2.4 version were used the problem did 
> not vanish.
> Greetings
> Christian
> Claus Ibsen schrieb:
>> Hi
>> Which version of Camel, spring and junit are you using?
>> We use junit 4.x to unit test many of the camel components. Such as
>> camel-jms, camel-quartz etc.

View raw message