camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: Error using camel-file with windows
Date Thu, 17 Sep 2009 10:31:02 GMT
I just create a JIRA[1] and committed a quick fix for it.
BTW, I also back ported the CAMEL-1936 into camel-1.x branch.

[1] https://issues.apache.org/activemq/browse/CAMEL-2020

Willem


Claus Ibsen wrote:
> On Thu, Sep 17, 2009 at 10:30 AM, Willem Jiang <willem.jiang@gmail.com> wrote:
>> Yes, we fixed the NPE of BundleContext[1] few month ago.
>> Maybe we need to back port this fix to camel 1.6.x.
>>
>> [1]  https://issues.apache.org/activemq/browse/CAMEL-1936
> 
> Yeah I think so if its easy and doable. SMX users will still be using
> Camel 1.x for some time in which they can still hit issues with OSGi.
> 
>> Willem
>>
>> Claus Ibsen wrote:
>>> On Thu, Sep 17, 2009 at 9:25 AM, TheWinch
>>> <vincent.girardreydet@thalesgroup.com> wrote:
>>>> Very strange behaviour.
>>>> I just stopped servicemix and restarted it (without clearing the bundles
>>>> cache) and .... booom, the component seems to work !
>>>>
>>>> I think my issue is more related to the Karaf container than to Camel.
>>>> The
>>>> fact is at the beginning my component had some missing dependencies, that
>>>> I
>>>> fixed. I kept updating the bundle. I even uninstalled/reinstalled it...
>>>> but
>>>> whithout restarting ServiceMix. Looking at the source where the NPE
>>>> occurs,
>>>> I see this:
>>>>
>>>> 82             BundleContext bundleContext =
>>>> Activator.getBundle().getBundleContext();
>>>> 83
>>>> 84             URL url;
>>>> 85             for (Bundle bundle : bundleContext.getBundles()) {
>>>>
>>>> So it seems that Karaf somehow did start the bundle with a NULL bundle
>>>> context. Very strange.....
>>>>
>>>> However now it works. Any idea where I could report my bug at best ?
>>> At ServiceMix User forum is a good spot.
>>>
>>> Willem Jiang is a committer at both SMX and Camel and works with OSGi
>>> and other stuff so he is an excellent candidate to look into this.
>>> But it could very well be a more general problem with hot deploying
>>> bundles.
>>>
>>> I recall similar issues that manifest in other errors that are
>>> remedied by restarting SMX.
>>> So I think its being looked into.
>>>
>>>
>>>> --
>>>> View this message in context:
>>>> http://www.nabble.com/Error-using-camel-file-with-windows-tp25475829p25486384.html
>>>> Sent from the Camel - Users mailing list archive at Nabble.com.
>>>>
>>>>
>>>
>>>
>>
> 
> 
> 


Mime
View raw message