camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <cmoulli...@gmail.com>
Subject Re: FUSE ESB 4.1.0.2: camel-mina feature will not install
Date Thu, 13 Aug 2009 15:25:48 GMT
Aaron,

Have you checked if another mina bundle is installed (2.0.0, ...) ?
Can you execute the command : headers 93 to have info about packages
imported/exported ?
It should be interesting to check using command packages to see which
packages are exported by mina 1.1.7 and which one are imported by Apache
Camel Mina ?
If by example Mina 2.0.0 is installed by defaukt on Fuse ESB 4, this is the
version 2.0.0 which is imported and not 1.1.7 resulting in a conflict.

Regards,

Charles Moulliard
Senior Enterprise Architect
Apache Camel Committer

*****************************
blog : http://cmoulliard.blogspot.com


On Thu, Aug 13, 2009 at 4:51 PM, ariekenb <aaron.j.riekenberg@lmco.com>wrote:

>
> Willem Jiang committed a change to add a version number on the mina imports
> in camel-mina (https://issues.apache.org/activemq/browse/CAMEL-1907).
>
> I checked out the current camel-1.x branch and built it and tried
> installing
> in FUSE ESB 4.1.0.2.
>
> First I installed the mina 1.1.7 bundle:
>
> install -s
>
> mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.mina/1.1.7_1
>
> Next I tried installing the camel-mina-1.6.2-SNAPSHOT bundle I built and
> got
> the error below:
>
> smx@root:osgi> install -s
>
> file:///home/ariekenb/.m2/repo/org/apache/camel/camel-mina/1.6.2-SNAPSHOT/camel-mina-1.6.2-SNAPSHOT.jar
> ERROR CommandLineExecutionFailed:
> org.apache.geronimo.gshell.command.CommandException:
> org.osgi.framework.BundleException: Unresolved constraint in bundle 93:
> package;
>
> (&(package=org.apache.mina.transport.vmpipe)(version>=1.1.7)(!(version>=2.0.0)))
>
>
> I do not understand why this error happens - the mina bundle is exporting
> org.apache.mina.transport.vmpipe version 1.1.7.  Any ideas?  Maybe someone
> else could try this in FUSE ESB 4.1.0.2?
>
> Thanks,
> Aaron
>
>
>
> Claus Ibsen-2 wrote:
> >
> > Hmm Mina 2.0 has not been released as final yet.
> >
> > I wonder what / why SMX suddenly uses 2.0x instead of 1.1.7 that is
> > the last stable release.
> > And I do not think camel-mina have OSGi version limitation to mina
> > 1.1.x in the manifest file.
> >
> >
> >
> >
> > On Wed, Aug 12, 2009 at 3:45 PM, ariekenb<aaron.j.riekenberg@lmco.com>
> > wrote:
> >>
> >> Running ESB 4.1.0.2, the camel-mina feature will not install:
> >>
> >> smx@root:features> install camel-mina
> >> ERROR CommandLineExecutionFailed:
> >> org.apache.geronimo.gshell.command.CommandException:
> >> org.osgi.framework.BundleException: Unresolved constraint in bundle 157:
> >> package; (package=org.apache.mina.common)
> >>
> >>
> >> It appears ESB 4.1.0.2 comes with mina version 2.0.0.M6, but camel-mina
> >> still depends on mina 1.1.x.  In ESB 4.1.0.0 a mina 1.1.7 bundle is
> >> included
> >> in the system directory.  No mina 1.1.x bundle is included with ESB
> >> 4.1.0.2,
> >> and there does not seem to be any mina 1.1.x bundle available on
> >> http://repo.open.iona.com.
> >>
> >> Is camel-mina currently broken in FUSE ESB 4.1.0.2?
> >> --
> >> View this message in context:
> >>
> http://www.nabble.com/FUSE-ESB-4.1.0.2%3A-camel-mina-feature-will-not-install-tp24936826p24936826.html
> >> Sent from the Camel - Users mailing list archive at Nabble.com.
> >>
> >>
> >
> >
> >
> > --
> > Claus Ibsen
> > Apache Camel Committer
> >
> > Open Source Integration: http://fusesource.com
> > Blog: http://davsclaus.blogspot.com/
> > Twitter: http://twitter.com/davsclaus
> >
> >
>
> --
> View this message in context:
> http://www.nabble.com/FUSE-ESB-4.1.0.2%3A-camel-mina-feature-will-not-install-tp24936826p24954941.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message