camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S. Ali Tokmen" <savas-ali.tok...@bull.net>
Subject [camel-cxf] Should we specify the CXF version required explicitely in the bundle?
Date Wed, 29 Jul 2009 09:07:55 GMT
(I'm not sure whether this shall be posted on the user or dev list)

Hello

The camel-cxf component has been generated against version 2.2.2. As a 
result, the camel-cxf module as well as the camel-cxf bundle requires 
CXF 2.2 (and does not work correctly with CXF 2.0 -which is expected due 
to API changes).

Now, the trouble is that the camel-cxf JAR's MANIFEST has an 
Import-Package on org.apache.cxf.* components without specifying any 
version! As a result, when it looks for CXF and both CXF 2.0 and 2.2 are 
present on the platform, it sometimes chooses the wrong one.

Could we add the version specifiers to the Import-Package declarations 
of the camel-cxf bundle?

Cheers

-- 

S. Ali Tokmen
savas-ali.tokmen@bull.net

Office: +33 4 76 29 76 19
GSM:    +33 66 43 00 555

Bull, Architect of an Open World TM
http://www.bull.com



Mime
View raw message