camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Re: Documenting the Camel DSL
Date Mon, 08 Jun 2009 22:12:31 GMT
Hi Charles,

we should really find a good word. I think macros would also be good. Is 
there a common opinion among the developers how to name them?
Grouping functions is a good idea. I propose to first leave out the EIP 
stuff at first as they are already quite well documented. For the start 
we could link to the EIP page.

Greetings

Christian

Charles Moulliard schrieb:
> Do you think name and excerpt could be enough if the class, examples and
> documentation are found in the detail page?
> yes.
>
> Nevertheless, I propose to group functions (Is it the right name ? --> could
> be macros, ) in the page :
> http://cwiki.apache.org/confluence/display/CAMEL/Camel+DSL
>
> A. Global / General
> - bean
> - choice
> - from
> - to
> - convertBodyTo
> - marshal
> - unmarshal
> - try/catch/finally
> - transacted
> - when
>
> B. EIP related
> - aggregate
> - delayer
> - filter
> - multicast
> - splitter
> - throttler
>
> Regards,
>
> Charles Moulliard
> Senior Enterprise Architect
> Apache Camel Committer
>
> *****************************
> blog : http://cmoulliard.blogspot.com
>
>
> On Sun, Jun 7, 2009 at 11:45 AM, Christian Schneider <
> chris@die-schneider.net> wrote:
>
>   


-- 

Christian Schneider
---
http://www.liquid-reality.de


Mime
View raw message