camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gert Vanthienen <gert.vanthie...@gmail.com>
Subject Re: JBI In-Only Exchange Never Completes
Date Wed, 27 May 2009 04:44:58 GMT
Bob,

This scenario should definitely work.  I regularly use Camel inside
ServiceMix with customers and most of the flows there are with InOnly
exchanges.  I've just added a few lines to a unit test of ours as
well, so it reads:

from("jbi:service:urn:test:forward").to("jbi:service:urn:test:in-only?mep=in-only");

from("jbi:service:urn:test:in-only").convertBodyTo(String.class).to("mock:done");

Is this what you're trying to do?  From what you're saying, I guess
you see the ACTIVE MessageExchange in the DEBUG log but there's no
DONE MessageExchange afterwards?  If that is the case, the likely
culprit is the provider component, the one that is actually receiving
the MessageExchange and handling it might not be setting the status
correctly.  Could you send us a brief summary of the flow
(components/endpoints used) to help us troubleshoot?

Regards,

Gert Vanthienen
------------------------
Open Source SOA: http://fusesource.com
Blog: http://gertvanthienen.blogspot.com/



2009/5/27 Bob Pollack <robert_h_pollack@yahoo.com>:
>
> Has anyone gotten an in-only JBI exchange to work? If I send a message to
> "jbi:service:foo:bar?mep=in-only", it works, but the exchange never seems to
> complete. That is, I can only do this once.
>
> Is this a bug, or am I doing something wrong? If anyone has a working
> example of sending to a JBI in-only exchange, I'd love to see it.
>
> Thanks.
> --
> View this message in context: http://www.nabble.com/JBI-In-Only-Exchange-Never-Completes-tp23732734p23732734.html
> Sent from the Camel - Users mailing list archive at Nabble.com.
>
>

Mime
View raw message