camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <>
Subject Re: thoughts on the method names for the requestBody and requestBodyAndHeader etc
Date Sat, 04 Apr 2009 07:20:16 GMT
On Sat, Apr 4, 2009 at 8:38 AM, Ryan Gardner <> wrote:
> The requestBody method makes sense (it requests a body) - but
> "requestBodyAndHeader" and "requestBodyAndHeaders" etc methods make less
> sense - because I'm only requesting one thing (the body).
> maybe "requestBodyWithHeader" makes more sense? for the "sendBodyAndHeader"
> methods, it makes sense because you are sending two things (the body and the
> header)
> although, perhaps I'm just going crazy?
No it makes sense. You only get the body as reply.

But to make it consistent the sendBodyAndHeader could also be named as

> Ryan

Claus Ibsen
Apache Camel Committer

Open Source Integration:
Apache Camel Reference Card:

View raw message