camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cmoulliard <cmoulli...@gmail.com>
Subject Re: Problem when deploying part 5 of Tutorial-Example-ReportIncident on Tomcat
Date Tue, 27 Jan 2009 12:55:25 GMT

Hi,

Can you provide the tomcat stack trace error generated when the web service
has been called please ?

Charles

O. Baujard wrote:
> 
> Hi,
> 
> I'm currently playing with the Tutorial-Example-ReportIncident. I have a
> problem when I try to deploy the war generated by maven on Tomcat. I
> managed to make Tomcat start properly after having add  the following
> <br><br>
> <code>
>    &lt;import resource="classpath:META-INF/cxf/cxf.xml"/&gt;<br>
>    &lt;import
> resource="classpath:META-INF/cxf/cxf-extension-soap.xml"/&gt;<br>
>    &lt;import
> resource="classpath:META-INF/cxf/cxf-servlet.xml"/&gt;<br><br>
> </code>
> 
> to the camel-config.xml file.
> 
> When I access the services url, I got a page listing the web service
> deployed :
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
> "http://www.w3.org/TR/html4/loose.dtd"><HTML><HEAD><LINK type="text/css"
> rel="stylesheet" href="/part-five/webservices/?stylesheet=1"><meta
> http-equiv=content-type content="text/html; charset=UTF-8"><title>CXF -
> Service list</title></head><body>Available services:<br /><table
> cellpadding="1" cellspacing="1" border="1"
> width="100%"><tr><td>ReportIncidentEndpoint<ul><li>ReportIncident</li></ul></td><td>Endpoint
> address: http://localhost:20000/part-five/webservices/incident<br />Wsdl: 
> http://localhost:20000/part-five/webservices/incident?wsdl
> {http://reportincident.example.camel.apache.org}ReportIncidentEndpointService
> <br />Target namespace:
> http://reportincident.example.camel.apache.org</td></tr></table></body></html>
> 
> but then when I click the url to obtain the wsdl, it fails, the message on
> the server side being :
> 
> Can't find the request for
> http://localhost:20000/part-five/webservices/incident's Observer
> 
> It seems the service is not correctly deployed.
> 
> Has anybody already tried to deploy this war on Tomcat ? Any pointer to
> solve this problem ?
> 
> Cheers,
> 
> Olivier
> 


-----
Charles Moulliard
SOA Architect

My Blog :  http://cmoulliard.blogspot.com/ http://cmoulliard.blogspot.com/  
-- 
View this message in context: http://www.nabble.com/Problem-when-deploying-part-5-of-Tutorial-Example-ReportIncident-on-Tomcat-tp21586670s22882p21683882.html
Sent from the Camel - Users mailing list archive at Nabble.com.


Mime
View raw message