camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen" <claus.ib...@gmail.com>
Subject Re: Various camel issues
Date Tue, 16 Dec 2008 05:21:24 GMT
On Tue, Dec 16, 2008 at 12:56 AM, Lars Ivar Igesund
<larsivar@igesund.net> wrote:
> Hi!
>
> We have a central routing application/server using spring and camel and AMQ,
> and various clients connecting to it.
>
> Now, for the last couple of months we've been using 1.4.0 which generally
> works fine. However, fairly often after a restart of the server app (it is
> still under development), it hangs as it replies to the first client to
> connect.
>
> I've not been able to get a stack trace, but the information I do have is that
> I use sendBodyAndHeaders from DefaultProducerTemplate instance, and that it
> logs ">>>> endpoint + " " + exchange" in ProducerCache.
Which kind of producer is it? JMS, Http etc? Have you enabled
DEBUG/TRACE logging for that producer. It might log a bit more where
it "hangs".

> Then I tried to upgrade to 1.5.0, this does however not work at all (it
> compiles without problems), as I get a NullPointerException on line 186 of
> component/bean/MethodInfo - seems like there is a null expression.
Could you paste the stacktrace and a bit more info on ths NPE? There
is a known issue if a message contains a null body and you use the
tracer to log it.

>
> Any hints on how to solve any of the above is highly appreciated.
>
> Regards,
> Lars Ivar Igesund
> (larsivi)
>



-- 

/Claus Ibsen
Apache Camel Committer
Blog: http://davsclaus.blogspot.com/

Mime
View raw message