camel-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conrad Pilloud <conrad.pill...@ngc.com>
Subject RE: Camel won't invoke my custom MINA codec
Date Fri, 05 Sep 2008 15:33:43 GMT

Thanks for the quick response.  Problem solved--my custom codec is now
faithfully de-chunking the socket within Camel 1.4.0.

Following your suggestion, I turned on debug logging by adding the following
to my POM.xml
<dependency>
    <groupId>log4j</groupId>
    <artifactId>log4j</artifactId>
    <version>1.2.12</version>
</dependency>
And by editing log4j.properties file under src/main/resources to from INFO
to DEBUG.

Sure enough, my codec bean, lcf, was not getting instantiated.
The culprit:  I had commented out the bean in my camel-context.xml earlier
in the day!!  Grrr.  

BTW, if anyone wants an example of implementing a custom codec, the MINA 
http://mina.apache.org/tutorial-on-protocolcodecfilter.html Tutorial on
ProtocolCodedFilter  is great.  I can e-mail my length-protocol
implementation if anyone is interested.

Cheers
Conrad


Claus Ibsen wrote:
> 
> Hi
> 
> When you use the codec Camel will look for a spring bean with the given
> id. But I guess you have tried with the bean id = lcf
> 
> You can enable DEBUG logging in Camel and it will output a bit more how it
> configures the mina component.
> 
> BTW: What version of Camel are you using?
> 
> 
> Med venlig hilsen
>  
> Claus Ibsen
> ......................................
> Silverbullet
> Skovsgårdsvænget 21
> 8362 Hørning
> Tlf. +45 2962 7576
> Web: www.silverbullet.dk
> 
-- 
View this message in context: http://www.nabble.com/Camel-won%27t-invoke-my-custom-MINA-codec-tp19322279s22882p19333803.html
Sent from the Camel - Users mailing list archive at Nabble.com.


Mime
View raw message